summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog9
-rwxr-xr-xdh_installchangelogs8
2 files changed, 11 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index dbc36f24..c6064b16 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,13 +1,16 @@
-debhelper (7.0.2) UNRELEASED; urgency=low
+debhelper (7.0.2) unstable; urgency=low
* dh: Optimise the case where the binary-arch or binary-indep sequence is
run and there are no packages of that type.
* dh_auto_configure: Set PERL_MM_USE_DEFAULT when configuring MakeMaker
packages to avoid interactive prompts.
* dh_auto_*: Also support packages using Module::Build.
- * dh_auto_*: Fix some calls to setup.py.
+ * dh_auto_*: Fix some calls to setup.py. Now tested and working with
+ python packages.
+ * dh_install: Find all possible cases of "changelog" and "changes", rather
+ than just looking for some predefined common cases.
- -- Joey Hess <joeyh@debian.org> Thu, 24 Apr 2008 14:10:56 -0400
+ -- Joey Hess <joeyh@debian.org> Thu, 24 Apr 2008 21:55:49 -0400
debhelper (7.0.1) unstable; urgency=low
diff --git a/dh_installchangelogs b/dh_installchangelogs
index 339313a2..3d7be50d 100755
--- a/dh_installchangelogs
+++ b/dh_installchangelogs
@@ -67,9 +67,11 @@ my $upstream=shift;
my $changelog_name="changelog.Debian";
if (! defined $upstream) {
if (! isnative($dh{MAINPACKAGE}) && !compat(6)) {
- foreach my $name (qw{ChangeLog Changelog Changes CHANGES changelog}) {
- if (-e $name) {
- $upstream=$name;
+ my @files=sort glob("*");
+ foreach my $name (qw{changelog changes}) {
+ my @matches=grep { lc $_ eq $name } @files;
+ if (@matches) {
+ $upstream=shift @matches;
last;
}
}