summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_strip2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 261dba60..f51a2eb4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (8.9.11) UNRELEASED; urgency=low
+
+ * Fix broken option passing to objcopy. Closes: #649044
+
+ -- Joey Hess <joeyh@debian.org> Thu, 17 Nov 2011 00:15:10 -0400
+
debhelper (8.9.10) unstable; urgency=low
* dh_strip: In v9, pass --compress-debug-sections to objcopy.
diff --git a/dh_strip b/dh_strip
index ae1594fe..4dc69616 100755
--- a/dh_strip
+++ b/dh_strip
@@ -170,7 +170,7 @@ sub make_debug {
doit($objcopy, "--only-keep-debug", $file, $debug_path);
}
else {
- doit($objcopy, "--only-keep-debug --compress-debug-sections", $file, $debug_path);
+ doit($objcopy, "--only-keep-debug", "--compress-debug-sections", $file, $debug_path);
}
# No reason for this to be executable.
doit("chmod", 644, $debug_path);