summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_shlibdeps5
2 files changed, 12 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index b948ec42..bd72d497 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -21,6 +21,13 @@ debhelper (7.3.0) UNRELEASED; urgency=low
-- Joey Hess <joeyh@debian.org> Mon, 20 Apr 2009 16:26:08 -0400
+debhelper (7.2.18) UNRELEASED; urgency=low
+
+ * dh_shlibdeps: Ensure DEBIAN directory exists, as dpkg-shlibdeps
+ prints a confusing warning if it does not. Closes: #534226
+
+ -- Joey Hess <joeyh@debian.org> Sun, 28 Jun 2009 15:59:11 -0400
+
debhelper (7.2.17) unstable; urgency=low
* Allow command-specific options to be passed to commands
diff --git a/dh_shlibdeps b/dh_shlibdeps
index 3ab89818..e5f73cba 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -112,6 +112,11 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
my $ext=pkgext($package);
+ # dpkg-shlibdeps expects this directory to exist
+ if (! -d "$tmp/DEBIAN") {
+ doit("install","-o",0,"-g",0,"-d","$tmp/DEBIAN");
+ }
+
my @filelist;
my $ff;