summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installdocs2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 30e54ea4..18052a71 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (5.0.10) unstable; urgency=low
+
+ * dh_installdocs: Fix bug introduced by empty file skipping that prevented
+ errors for nonexistent files. Closes: #342729
+
+ -- Joey Hess <joeyh@debian.org> Fri, 9 Dec 2005 18:05:15 -0500
+
debhelper (5.0.9) unstable; urgency=low
* dh_installmodules: always run depmod, since if module-init-tools but not
diff --git a/dh_installdocs b/dh_installdocs
index eb7d126c..52ad21d0 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -127,7 +127,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
foreach my $doc (@docs) {
next if excludefile($doc);
- next if ! -s $doc && ! compat(4); # ignore empty BUGS, etc
+ next if -e $doc && ! -s $doc && ! compat(4); # ignore empty BUGS, etc
if (-d $doc && $exclude) {
my ($dir_basename) = basename($doc);
# Pity there's no cp --exclude ..