summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_shlibdeps2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 5b713caf..31ee561a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (2.0.49) unstable; urgency=low
+
+ * dh_shlibdeps: detect statically linked binaries and don't pass them to
+ dpkg-shlibdeps.
+
+ -- Joey Hess <joeyh@master.debian.org> Fri, 17 Sep 1999 00:28:59 -0700
+
debhelper (2.0.48) unstable; urgency=low
* 4 whole days without a debhelper upload! Can't let that happen. Let's see..
diff --git a/dh_shlibdeps b/dh_shlibdeps
index bd733b37..cdf13566 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -17,7 +17,7 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
foreach $file (split(/\n/,`find $TMP -type f \\( -perm +111 -or -name "*.so*" \\)`)) {
# TODO: this is slow, optimize. Ie, file can run once on multiple files..
$ff=`file "$file"`;
- if ($ff=~m/ELF/) {
+ if ($ff=~m/ELF/ && ! $ff=~/statically linked/) {
push @filelist,$file;
}
}