summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postinst-modules2
-rw-r--r--autoscripts/postrm-modules2
-rw-r--r--debian/changelog4
3 files changed, 6 insertions, 2 deletions
diff --git a/autoscripts/postinst-modules b/autoscripts/postinst-modules
index babf39bd..f2342da4 100644
--- a/autoscripts/postinst-modules
+++ b/autoscripts/postinst-modules
@@ -1,3 +1,3 @@
if [ "$1" = "configure" ] && [ -x /sbin/update-modules ]; then
- update-modules >/dev/null
+ update-modules >/dev/null || [ "$?" = 3 ]
fi
diff --git a/autoscripts/postrm-modules b/autoscripts/postrm-modules
index f2d4cb7a..804f6329 100644
--- a/autoscripts/postrm-modules
+++ b/autoscripts/postrm-modules
@@ -1,3 +1,3 @@
if [ -x /sbin/update-modules ]; then
- update-modules >/dev/null
+ update-modules >/dev/null || [ "$?" = 3]
fi
diff --git a/debian/changelog b/debian/changelog
index e93b37af..3e23321b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,10 @@
debhelper (4.2.33) UNRELEASED; urgency=low
* Update Spanish translation of dh_clean man page. Closes: #303052
+ * dh_installmodules autoscripts: Now that return code 3 is allocated by
+ update-modules to indicate /etc/modules.conf is not automatically
+ generated, we can ignore that return code since it's not a condition that
+ should fail an installation. Closes: #165400
-- Joey Hess <joeyh@debian.org> Sat, 9 Apr 2005 17:27:12 -0400