summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Lib.pm6
-rw-r--r--debian/changelog7
2 files changed, 10 insertions, 3 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 42d40974..e71895e4 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -271,7 +271,7 @@ sub pkgext { my $package=shift;
# Get the package version.
my $version=`dpkg-parsechangelog -l$isnative_changelog`;
- ($dh{VERSION})=$version=~m/Version: (.*)/m;
+ ($dh{VERSION})=$version=~m/Version:\s*(.*)/m;
# Did the changelog parse fail?
if (! defined $dh{VERSION}) {
@@ -371,10 +371,10 @@ sub GetPackages { my $type=shift;
while (<CONTROL>) {
chomp;
s/\s+$//;
- if (/^Package:\s+(.*)/) {
+ if (/^Package:\s*(.*)/) {
$package=$1;
}
- if (/^Architecture:\s+(.*)/) {
+ if (/^Architecture:\s*(.*)/) {
$arch=$1;
}
if (!$_ or eof) { # end of stanza.
diff --git a/debian/changelog b/debian/changelog
index 9b2bb0c0..5109994c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (2.1.10) unstable; urgency=low
+
+ * Modified to allow no spaces between control file field name and value
+ (this appears to be logal).
+
+ -- Joey Hess <joeyh@debian.org> Tue, 19 Sep 2000 23:13:17 -0700
+
debhelper (2.1.9) unstable; urgency=low
* dh_installmodules: corrected the code added to maintainer scripts so it