summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog13
-rwxr-xr-xexamples/rules5
-rwxr-xr-xexamples/rules.indep3
-rwxr-xr-xexamples/rules.multi5
-rwxr-xr-xexamples/rules.multi29
5 files changed, 22 insertions, 13 deletions
diff --git a/debian/changelog b/debian/changelog
index 394e2aac..2d5cb310 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+debhelper (2.0.56) unstable; urgency=low
+
+ * Fiddlesticks. The neat make trick I was using in rules.multi2 failed if
+ you try to build binary-indep and binary-arch targets in the same make
+ run. Make tries to be too smart. Modified the file so it will work,
+ though it's now uglier. Closes: 46287
+ * examples/*: It's important that one -not- use a install-stamp target.
+ Install should run every time binary-* calls it. Otherwise if a binary-*
+ target is called twice by hand, you get duplicate entries in the
+ maintainer script fragment files. Closes: #46313
+
+ -- Joey Hess <joeyh@master.debian.org> Thu, 30 Sep 1999 12:01:40 -0700
+
debhelper (2.0.55) unstable; urgency=low
* Fixed quoting problem in examples/rules.multi (Closes: #46254)
diff --git a/examples/rules b/examples/rules
index d24c2b8f..d2d9f5d0 100755
--- a/examples/rules
+++ b/examples/rules
@@ -20,7 +20,7 @@ build-stamp:
clean:
dh_testdir
dh_testroot
- rm -f build-stamp install-stamp
+ rm -f build-stamp
# Add here commands to clean up after the build process.
#-$(MAKE) clean
@@ -28,8 +28,7 @@ clean:
dh_clean
-install: install-stamp
-install-stamp: build-stamp
+install:
dh_testdir
dh_testroot
dh_clean -k
diff --git a/examples/rules.indep b/examples/rules.indep
index ecda654a..7b474a10 100755
--- a/examples/rules.indep
+++ b/examples/rules.indep
@@ -30,8 +30,7 @@ clean:
dh_clean
-install: install-stamp
-install-stamp: build-stamp
+install:
dh_testdir
dh_testroot
dh_clean -k
diff --git a/examples/rules.multi b/examples/rules.multi
index fe8cc975..f16b3e64 100755
--- a/examples/rules.multi
+++ b/examples/rules.multi
@@ -35,9 +35,8 @@ clean:
dh_clean
-install: install-stamp
-install-stamp: DH_OPTIONS=
-install-stamp: build-stamp
+install: DH_OPTIONS=
+install: build-stamp
dh_testdir
dh_testroot
dh_clean -k
diff --git a/examples/rules.multi2 b/examples/rules.multi2
index 871c41c7..1f773311 100755
--- a/examples/rules.multi2
+++ b/examples/rules.multi2
@@ -83,13 +83,12 @@ binary-common:
# Build architecture independant packages using the common target.
# (Uncomment the next two lines and comment out the third if you have
# such packages)
-#binary-indep: DH_OPTIONS=-i
-#binary-indep: build install binary-common
-binary-indep:
+#binary-indep:
+# $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
# Build architecture dependant packages using the common target.
-binary-arch: DH_OPTIONS=-a
-binary-arch: build install binary-common
+binary-arch:
+ $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
# Any other binary targets build just one binary package at a time.
binary-%: build install