summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Lib.pm5
-rw-r--r--debian/changelog6
2 files changed, 10 insertions, 1 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index b14afd1e..d1c67b53 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -52,7 +52,10 @@ sub init {
if ($dh{EXCLUDE}) {
$dh{EXCLUDE_FIND}='';
foreach (@{$dh{EXCLUDE}}) {
- $dh{EXCLUDE_FIND}.="-regex ".escape_shell(".*$_.*")." -or ";
+ my $x=$_;
+ $x=escape_shell($x);
+ $x=~s/\./\\\\./g;
+ $dh{EXCLUDE_FIND}.="-regex .\\*$x.\\* -or ";
}
$dh{EXCLUDE_FIND}=~s/ -or $//;
}
diff --git a/debian/changelog b/debian/changelog
index dc4bb832..0429fd91 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (4.0.8) unstable; urgency=low
+
+ * Don't leak regex characters from -X when generating DH_EXCLUDE_FIND.
+
+ -- Joey Hess <joeyh@debian.org> Wed, 22 May 2002 21:03:38 -0400
+
debhelper (4.0.7) unstable; urgency=low
* dh_strip: If a file is an ELF shared binary, does not have a .so.* in its