summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_installman5
2 files changed, 10 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 53445c5d..594ef7c8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (7.4.21) UNRELEASED; urgency=low
+
+ * dh_installman: Support .so links relative to the current section.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 17 May 2010 20:01:19 -0400
+
debhelper (7.4.20) unstable; urgency=low
* Drop one more call to dpkg-architecture. Closes: #580837
diff --git a/dh_installman b/dh_installman
index 8487f100..1a5750b8 100755
--- a/dh_installman
+++ b/dh_installman
@@ -241,7 +241,10 @@ sub find_so_man {
dirname($solink)) {
$solink=basename($solink);
}
- else {
+ # A so link with a path is relative to the base of the man
+ # page hierarchy, but without a path, is relative to the
+ # current section.
+ elsif ($solink =~ m!/!) {
$solink="../$solink";
}