summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rwxr-xr-xdh_installdebconf34
3 files changed, 14 insertions, 28 deletions
diff --git a/debian/changelog b/debian/changelog
index d5f4bf0a..ecf156bf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,8 +2,12 @@ debhelper (5.0.23) UNRELEASED; urgency=low
* dh_strip: remove binutils build-dep lines since stable has a new enough
version. Closes: #350607
+ * dh_installdebconf: drop all support for old-style translated debconf
+ templates files via debconf-mergetemplate (keep a warning if any are
+ found, for now). Allows dropping debhelper's dependency on
+ debconf-utils. Closes: #331796
- -- Joey Hess <joeyh@debian.org> Mon, 30 Jan 2006 16:57:21 -0500
+ -- Joey Hess <joeyh@debian.org> Mon, 20 Feb 2006 16:35:50 -0500
debhelper (5.0.22) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 5055608a..83281261 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Build-Depends-Indep: po4a (>= 0.23)
Package: debhelper
Architecture: all
-Depends: ${perl:Depends}, ${misc:Depends}, coreutils | fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.13.13), html2text, debconf-utils (>= 1.1.1), binutils, po-debconf
+Depends: ${perl:Depends}, ${misc:Depends}, coreutils | fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.13.13), html2text, binutils, po-debconf
Suggests: dh-make
Conflicts: dpkg-cross (<< 1.18)
Description: helper programs for debian/rules
diff --git a/dh_installdebconf b/dh_installdebconf
index 015e3e5f..b1a23453 100755
--- a/dh_installdebconf
+++ b/dh_installdebconf
@@ -41,20 +41,10 @@ do it right.
=head1 LOCALIZED TEMPLATE FILES
-Debconf also supports localized template files, and this program has some
-support to aid is working with them. It is best to keep the translations in
-.po files under debian/po, and merge them only at build time. See
-L<po2debconf(1)> and L<debconf-getlang(1)> for details.
-
-This program will look to see if you have a debian/po directory and if so will
-automatically call L<po2debconf(1)> to generate a merged templates file. Or
-if you have debian/templates.ll files, it will use the older
-L<debconf-mergetemplate(1)> program to merge those together.
-
-Note that if your package has a debian/po directory it should build-depend on po-debconf.
-
-For example, if you have a German translation,
-strings from debian/po/de.po are merged with debian/package.templates.
+This program will look to see if you have a debian/po directory and if so
+will automatically call L<po2debconf(1)> to generate a merged templates
+file containing the translations. For this to work, your package should
+build-depend on po-debconf.
=head1 OPTIONS
@@ -66,8 +56,7 @@ Do not modify postrm script.
=item B<--> I<params>
-Pass the params to po2debconf, if it is run or debconf-mergetemplate, if it
-is run.
+Pass the params to po2debconf.
=back
@@ -95,22 +84,15 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if ($templates ne '') {
# Are there old-style translated templates?
- my @trans=(glob("$templates.??"), glob("$templates.??_??"));
+ if (glob("$templates.??"), glob("$templates.??_??")) {
+ warning "Ignoring debian/templates.ll files. Switch to po-debconf!";
+ }
umask(0022); # since I do a redirect below
- # Look for po directory.
if (-d "debian/po") {
- if (@trans) {
- warning "ignoring debian/templates.ll files in favour of debian/po directory";
- }
complex_doit("po2debconf @extraparams $templates > $tmp/DEBIAN/templates");
}
- elsif (@trans) {
- complex_doit("debconf-mergetemplate --drop-old-templates @extraparams @trans $templates > $tmp/DEBIAN/templates");
- chmod 0644, "$tmp/DEBIAN/templates";
- chown 0, 0, "$tmp/DEBIAN/templates";
- }
else {
doit("install", "-o", 0, "-g", 0, "-m", 644, "-p",
$templates, "$tmp/DEBIAN/templates");