summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_strip5
2 files changed, 11 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 05c64c44..c5bc10d2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (2.1.6) unstable; urgency=low
+
+ * dh_strip: now knows about the DEB_BUILD_OPTIONS=nostrip thing.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2000 16:28:31 -0700
+
debhelper (2.1.5) unstable; urgency=low
* dh_installxfonts: corrected a problem during package removal that was
diff --git a/dh_strip b/dh_strip
index b39d4655..b1501920 100755
--- a/dh_strip
+++ b/dh_strip
@@ -6,6 +6,11 @@ use File::Find;
use Debian::Debhelper::Dh_Lib;
init();
+# This variable can be used to turn off stripping (see Policy).
+if (defined $ENV{DEB_BUILD_OPTIONS} && $ENV{DEB_BUILD_OPTIONS} =~ /nostrip/) {
+ exit;
+}
+
# Check if a file is an elf binary, shared library, or static library,
# for use by File::Find. It'll fill the following 3 arrays with anything
# it finds: