summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postinst-icons2
-rw-r--r--debian/changelog7
2 files changed, 8 insertions, 1 deletions
diff --git a/autoscripts/postinst-icons b/autoscripts/postinst-icons
index d35f30c0..951b613d 100644
--- a/autoscripts/postinst-icons
+++ b/autoscripts/postinst-icons
@@ -1,6 +1,6 @@
if which gtk-update-icon-cache >/dev/null 2>&1; then
for dir in #DIRLIST#; do
- if [ -f "$dir"/icon-theme.cache ]; then
+ if [ -f "$dir"/index.theme ] && [ -f "$dir"/icon-theme.cache ]; then
gtk-update-icon-cache --force --quiet "$dir"
fi
done
diff --git a/debian/changelog b/debian/changelog
index 4abd07fd..bdc42ea4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (5.0.53) unstable; urgency=low
+
+ * dh_icons: Check for index.theme files before updating the cache.
+ Closes: #432824
+
+ -- Joey Hess <joeyh@debian.org> Fri, 13 Jul 2007 14:51:00 -0400
+
debhelper (5.0.52) unstable; urgency=low
* Remove DOS line endings from dh_icons scriptlets. Thanks, Daniel Holbach.