summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitattributes1
-rw-r--r--autoscripts/postinst-emacsen4
-rw-r--r--autoscripts/preinst-emacsen5
-rw-r--r--autoscripts/prerm-emacsen4
-rw-r--r--debian/changelog15
-rw-r--r--debian/control3
-rwxr-xr-xdh_installchangelogs8
-rwxr-xr-xdh_installemacsen26
8 files changed, 53 insertions, 13 deletions
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 00000000..5d425843
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1 @@
+debian/changelog merge=dpkg-mergechangelogs
diff --git a/autoscripts/postinst-emacsen b/autoscripts/postinst-emacsen
index f80e1dbd..6a46d79f 100644
--- a/autoscripts/postinst-emacsen
+++ b/autoscripts/postinst-emacsen
@@ -1,4 +1,4 @@
-if [ "$1" = "configure" ] && [ -x /usr/lib/emacsen-common/emacs-package-install ]
+if [ "$1" = "configure" ] && [ -e /var/lib/emacsen-common/state/package/installed/emacsen-common ]
then
- /usr/lib/emacsen-common/emacs-package-install #PACKAGE#
+ /usr/lib/emacsen-common/emacs-package-install --postinst #PACKAGE#
fi
diff --git a/autoscripts/preinst-emacsen b/autoscripts/preinst-emacsen
new file mode 100644
index 00000000..780fc697
--- /dev/null
+++ b/autoscripts/preinst-emacsen
@@ -0,0 +1,5 @@
+if ( [ "$1" = "install" ] || [ "$1" = "upgrade" ] ) \
+ && [ -e /var/lib/emacsen-common/state/package/installed/emacsen-common ]
+then
+ /usr/lib/emacsen-common/emacs-package-install --preinst #PACKAGE#
+fi
diff --git a/autoscripts/prerm-emacsen b/autoscripts/prerm-emacsen
index 8c3ca64c..31ecfaa4 100644
--- a/autoscripts/prerm-emacsen
+++ b/autoscripts/prerm-emacsen
@@ -1,3 +1,3 @@
-if [ -x /usr/lib/emacsen-common/emacs-package-remove ] ; then
- /usr/lib/emacsen-common/emacs-package-remove #PACKAGE#
+if [ -e /var/lib/emacsen-common/state/package/installed/emacsen-common ] ; then
+ /usr/lib/emacsen-common/emacs-package-remove --prerm #PACKAGE#
fi
diff --git a/debian/changelog b/debian/changelog
index 948e2f55..57f4983c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+debhelper (9.20130922) UNRELEASED; urgency=low
+
+ [ Joey Hess ]
+ * Debhelper is now team maintained. There is a
+ debhelper-devel@lists.alioth.debian.org mailing list which
+ maintainers of other dh_ commands are encouraged to join also.
+ * dh_installchangelogs: Avoid installing binNMU changelog file
+ in --no-act mode. Closes: #726930
+
+ [ Modestas Vainius ]
+ * Update dh_installemacsen and related scripts to follow emacs
+ policy v2.0 (as of emacsen-common 2.0.5). Closes: #728620
+
+ -- Joey Hess <joeyh@debian.org> Sun, 20 Oct 2013 19:18:44 -0400
+
debhelper (9.20130921) unstable; urgency=low
* dh: Call dh_installxfonts after dh_link, so that it will
diff --git a/debian/control b/debian/control
index 641e5acb..09135f45 100644
--- a/debian/control
+++ b/debian/control
@@ -1,7 +1,8 @@
Source: debhelper
Section: devel
Priority: optional
-Maintainer: Joey Hess <joeyh@debian.org>
+Maintainer: Debhelper Maintainers <debhelper-devel@lists.alioth.debian.org>
+Uploaders: Joey Hess <joeyh@debian.org>
Build-Depends: po4a (>= 0.24)
Standards-Version: 3.9.4
Vcs-Git: git://git.debian.org/git/debhelper/debhelper.git
diff --git a/dh_installchangelogs b/dh_installchangelogs
index 2f65f8a7..edd7f9f3 100755
--- a/dh_installchangelogs
+++ b/dh_installchangelogs
@@ -200,9 +200,11 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
doit("install","-d","$tmp/usr/share/doc/$package");
}
- if (! install_binNMU_changelog($package, $changelog, $changelog_name)) {
- doit("install","-o",0,"-g",0,"-p","-m644",$changelog,
- "$tmp/usr/share/doc/$package/$changelog_name");
+ if (! $dh{NO_ACT}) {
+ if (! install_binNMU_changelog($package, $changelog, $changelog_name)) {
+ doit("install","-o",0,"-g",0,"-p","-m644",$changelog,
+ "$tmp/usr/share/doc/$package/$changelog_name");
+ }
}
if (-e $news) {
diff --git a/dh_installemacsen b/dh_installemacsen
index 92037f20..b2ee1426 100755
--- a/dh_installemacsen
+++ b/dh_installemacsen
@@ -19,15 +19,20 @@ B<dh_installemacsen> is a debhelper program that is responsible for installing
files used by the Debian B<emacsen-common> package into package build
directories.
-It also automatically generates the F<postinst> and F<prerm> commands needed to
-register a package as an Emacs add on package. The commands are added to
-the maintainer scripts by B<dh_installdeb>. See L<dh_installdeb(1)>
-for an explanation of how this works.
+It also automatically generates the F<preinst> F<postinst> and F<prerm>
+commands needed to register a package as an Emacs add on package. The commands
+are added to the maintainer scripts by B<dh_installdeb>. See
+L<dh_installdeb(1)> for an explanation of how this works.
=head1 FILES
=over 4
+=item debian/I<package>.emacsen-compat
+
+Installed into F<usr/lib/emacsen-common/packages/compat/package> in the
+package build directory.
+
=item debian/I<package>.emacsen-install
Installed into F<usr/lib/emacsen-common/packages/install/package> in the
@@ -83,15 +88,23 @@ if (! defined $dh{FLAVOR}) {
$dh{FLAVOR}='emacs';
}
-# PROMISE: DH NOOP WITHOUT emacsen-install emacsen-remove emacsen-startup
+# PROMISE: DH NOOP WITHOUT emacsen-common emacsen-install emacsen-remove emacsen-startup
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
+ my $emacsen_compat=pkgfile($package,"emacsen-compat");
my $emacsen_install=pkgfile($package,"emacsen-install");
my $emacsen_remove=pkgfile($package,"emacsen-remove");
my $emacsen_startup=pkgfile($package,"emacsen-startup");
+ if ($emacsen_compat ne '') {
+ if (! -d "$tmp/usr/lib/emacsen-common/packages/compat") {
+ doit("install","-d","$tmp/usr/lib/emacsen-common/packages/compat");
+ }
+ doit("install","-m0644",$emacsen_compat,"$tmp/usr/lib/emacsen-common/packages/compat/$package");
+ }
+
if ($emacsen_install ne '') {
if (! -d "$tmp/usr/lib/emacsen-common/packages/install") {
doit("install","-d","$tmp/usr/lib/emacsen-common/packages/install");
@@ -115,6 +128,8 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if ($emacsen_install ne '' || $emacsen_remove ne '') {
if (! $dh{NOSCRIPTS}) {
+ autoscript($package,"preinst","preinst-emacsen",
+ "s/#PACKAGE#/$package/");
autoscript($package,"postinst","postinst-emacsen",
"s/#PACKAGE#/$package/");
autoscript($package,"prerm","prerm-emacsen",
@@ -126,6 +141,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
=head1 SEE ALSO
L<debhelper(7)>
+L</usr/share/doc/emacsen-common/debian-emacs-policy.gz>
This program is a part of debhelper.