summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog14
-rwxr-xr-xdh_installinit6
2 files changed, 14 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index c5ff76d2..d596288b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+debhelper (9.20131110) unstable; urgency=low
+
+ * dh_installinit: Revert changes that added versioned dependency on
+ sysv-rc to support upstart, which later grew to a versioned dependency
+ on sysv-rc | file-rc, and which seems to want to continue growing
+ to list other init systems, which there currently seem to be far too
+ many of, for far too little benefit.
+ The sysv-rc dependency is already met in stable.
+ The file-rc dependency is not, so if someone cares about that, they
+ need to find a properly designed solution, which this was not.
+ Closes: #729248
+
+ -- Joey Hess <joeyh@debian.org> Sun, 10 Nov 2013 15:23:29 -0400
+
debhelper (9.20131105) unstable; urgency=low
* Fix (horrible) make output parsing code to work with make 4.0.
diff --git a/dh_installinit b/dh_installinit
index d7c8f75d..1926e9fa 100755
--- a/dh_installinit
+++ b/dh_installinit
@@ -234,12 +234,6 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my $init=pkgfile($package,$scriptsrc) || pkgfile($package,"init") ||
pkgfile($package,"init.d");
- if ($job ne '' || ($dh{ONLYSCRIPTS} && -e "$tmp/etc/init/$jobfile.conf")) {
- # minimal version of invoke-rc.d that supports upstart jobs
- # directly
- addsubstvar($package, "misc:Depends", "sysv-rc (>= 2.88dsf-24) | file-rc (>= 0.8.16)");
- }
-
if ($init ne '' && ! $dh{ONLYSCRIPTS}) {
if (! -d "$tmp/etc/init.d") {
doit("install","-d","$tmp/etc/init.d");