summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_gencontrol6
2 files changed, 7 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 673b2a28..7093ca85 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,6 +12,12 @@ debhelper (9.20140210) UNRELEASED; urgency=medium
* perl_build: Use realclean instead of distclean. Closes: #737662
* Initial implementation of support for Build-Profiles fields.
Thanks, Daniel Schepler.
+ * dh_gencontrol: Revert change made in version 4.0.13 that avoided
+ passing -p to dpkg-gencontrol when only operating on one package.
+ There seems to be no benefit to doing that, and it breaks when using
+ Build-Profiles, since while debhelper may know a profile only allows
+ for one package, dpkg-gencontrol may see other packages in the
+ control file.
-- Joey Hess <joeyh@debian.org> Sat, 25 Jan 2014 15:49:45 -0400
diff --git a/dh_gencontrol b/dh_gencontrol
index 32b85637..41e09cbe 100755
--- a/dh_gencontrol
+++ b/dh_gencontrol
@@ -65,11 +65,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
# Generate and install control file.
- my @command="dpkg-gencontrol";
- if (getpackages() > 1) {
- push @command, "-p$package";
- }
- doit(@command, "-l$changelog", "-T$substvars",
+ doit("dpkg-gencontrol", "-p$package", "-l$changelog", "-T$substvars",
"-P$tmp",@{$dh{U_PARAMS}});
# This chmod is only necessary if the user sets the umask to