summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rwxr-xr-xdh_makeshlibs1
-rwxr-xr-xdh_shlibdeps1
3 files changed, 4 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index d7cdd3b4..217d1fa6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-debhelper (7.2.3-1) unstable; urgency=low
+debhelper (7.2.3) unstable; urgency=low
* dh_installmenus: Now that a triggers capable menu and dpkg are in
stable, menu does not need to be explicitly run in maintainer
@@ -11,6 +11,8 @@ debhelper (7.2.3-1) unstable; urgency=low
* dh_installchangelogs: Support -X to exclude automatic installation
of specific upstream changelogs. re-Closes: #490937
* Compatability level 4 is now deprecated.
+ * dh_makeshlibs: Re-add --add-udeb support. Closes: #518655
+ * dh_shlibdeps: Remove --add-udeb switch (was accidentially added here).
-- Joey Hess <joeyh@debian.org> Sat, 07 Mar 2009 14:52:20 -0500
diff --git a/dh_makeshlibs b/dh_makeshlibs
index 0eb96b02..1ece98de 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -108,6 +108,7 @@ init(options => {
"m=s", => \$dh{M_PARAMS},
"major=s" => \$dh{M_PARAMS},
"version-info:s" => \$dh{V_FLAG},
+ "add-udeb" => \$dh{SHLIBS_UDEB},
});
foreach my $package (@{$dh{DOPACKAGES}}) {
diff --git a/dh_shlibdeps b/dh_shlibdeps
index 320f2501..7b974eb8 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -87,7 +87,6 @@ on libbar1 as follows:
init(options => {
"L|libpackage=s" => \$dh{LIBPACKAGE},
- "add-udeb=s" => \$dh{SHLIBS_UDEB},
"dpkg-shlibdeps-params=s", => \$dh{U_PARAMS},
"l=s", => \$dh{L_PARAMS},
});