summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm2
-rw-r--r--debian/changelog4
2 files changed, 5 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 4795b7c3..81cff3c9 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -155,7 +155,7 @@ sub setup_py {
}
foreach my $python (@python_dbg, @python_requested) {
- if (-x "/usr/bin/".$python) {
+ if (-f "/usr/lib/$python/distutils/__init__.py") {
# To allow backports of debhelper we don't pass
# --install-layout=deb to 'setup.py install` for
# those Python versions where the option is
diff --git a/debian/changelog b/debian/changelog
index dd7b9a12..489e539d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,10 @@ debhelper (9.20120609) UNRELEASED; urgency=low
Thanks, Charles Plessy
* python distutils buildsystem: Propigate failure of pyversions.
Closes: #683551 Thanks, Clint Byrum
+ * python distutils buildsystem: When checking if a version of python is
+ installed, don't trust the presense of the executable, as
+ a python2.X-minimal package may provide it while not having
+ distutils installed. Closes: #683557
* dh_icons: Improve documentation. Closes: #684895
-- Joey Hess <joeyh@debian.org> Thu, 05 Jul 2012 08:51:07 -0600