summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules2
-rwxr-xr-xdh_builddeb6
4 files changed, 12 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index e5e7b936..54693a67 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.1.26) unstable; urgency=low
+
+ * dh_builddeb: Reluctantly call dpkg-deb directly. dpkg cannot pass extra
+ params to dpkg-deb. Closes: #170330
+
+ -- Joey Hess <joeyh@debian.org> Sun, 24 Nov 2002 11:14:36 -0500
+
debhelper (4.1.25) unstable; urgency=low
* Added a dh_python command, by Josselin Mouette
diff --git a/debian/control b/debian/control
index 28c16b6c..a699d728 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
Build-Depends-Indep: perl (>= 5.6.1), coreutils | fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.9.0)
-Standards-Version: 3.5.7.1
+Standards-Version: 3.5.8.0
Package: debhelper
Architecture: all
diff --git a/debian/rules b/debian/rules
index a3ff112e..ab30a3e5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -84,7 +84,7 @@ binary-indep: build
./dh_installdeb
./dh_gencontrol
./dh_md5sums
- ./dh_builddeb -v
+ ./dh_builddeb
# Update the debhelper web page. Not intended for use by anyone except the
# author.
diff --git a/dh_builddeb b/dh_builddeb
index 04b40f84..54c4362f 100755
--- a/dh_builddeb
+++ b/dh_builddeb
@@ -15,7 +15,7 @@ B<dh_builddeb> [S<I<debhelper options>>] [B<--destdir=>I<directory>] [B<--filena
=head1 DESCRIPTION
-dh_builddeb simply calls L<dpkg(8)> to build a debian package or
+dh_builddeb simply calls L<dpkg-deb(8)> to build a debian package or
packages.
=head1 OPTIONS
@@ -36,7 +36,7 @@ file name. Does not work well if more than one .deb is generated!
=item B<--> I<params>
-Pass I<params> to L<dpkg(1)|dpkg> when it is used to build the
+Pass I<params> to L<dpkg-deb(1)> when it is used to build the
package.
=back
@@ -62,7 +62,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (exists $ENV{DH_ALWAYS_EXCLUDE} && length $ENV{DH_ALWAYS_EXCLUDE}) {
complex_doit("find $tmp -name $ENV{DH_ALWAYS_EXCLUDE} | xargs rm -rf");
}
- doit("dpkg","--build",$tmp,"$dh{DESTDIR}$dh{FILENAME}",@{$dh{U_PARAMS}});
+ doit("dpkg-deb", @{$dh{U_PARAMS}}, "--build", $tmp, $dh{DESTDIR}.$dh{FILENAME});
}
=head1 SEE ALSO