summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installdebconf35
-rw-r--r--doc/TODO2
3 files changed, 33 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index c4a59003..4e79590d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.1.13) unstable; urgency=low
+
+ * dh_installdebconf: Support po-debconf debian/po directories.
+ Closes: #163128
+
+ -- Joey Hess <joeyh@debian.org> Wed, 2 Oct 2002 23:41:51 -0400
+
debhelper (4.1.12) unstable; urgency=low
* The "reverse hangover" release.
diff --git a/dh_installdebconf b/dh_installdebconf
index 3b56eb27..be6fcabf 100755
--- a/dh_installdebconf
+++ b/dh_installdebconf
@@ -31,17 +31,19 @@ Note that if you use debconf, your package probably needs to depend on it
=head1 LOCALIZED TEMPLATE FILES
Debconf also supports localized template files, and this program has some
-support to aid working with them. It is best to keep the translations in
-separate files, and merge them only at build time. See
-L<debconf-mergetemplate(1)> and L<debconf-getlang(1)> for details.
+support to aid is working with them. It is best to keep the translations in
+.po files under debian/po, and merge them only at build time. See
+L<po2debconf(1)> and L<debconf-getlang(1)> for details.
-This program will automatically call debconf-mergetemplate and merge
-templates on the fly if it finds your template files are accompanied
-by translated files that have the same name as the template file, with a
-dot and a locale name prepended.
+This program will look to see if you have a debian/po directory and if so will
+automatically call L<po2debconf(1)> to generate a merged templates file. Or
+if you have debian/templates.ll files, it will use the older
+L<debconf-mergetemplate(1)> program to merge those together.
+
+Note that if your package has a debian/po directory it should build-depend on po-debconf.
For example, if you have a German translation,
-debian/package.templates.de is merged with debian/package.templates.
+strings from debian/po/de.po are merged with debian/package.templates.
=head1 OPTIONS
@@ -53,7 +55,8 @@ Do not modify postrm script.
=item B<--> I<params>
-Pass the params to debconf-mergetemplate.
+Pass the params to po2debconf, if it is run or debconf-mergetemplate, if it
+is run.
=back
@@ -81,9 +84,19 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
if ($templates ne '') {
- # Are there translated templates too?
+ # Are there old-style translated templates?
my @trans=(glob("$templates.??"), glob("$templates.??_??"));
- if (@trans) {
+
+ # Look for po directory.
+ if (-d "debian/po") {
+ if (@trans) {
+ warning "ignoring debian/templates.ll files in favour of debian/po directory";
+ }
+ else {
+ complex_doit("po2debconf @extraparams $templates > $tmp/DEBIAN/templates");
+ }
+ }
+ elsif (@trans) {
complex_doit("debconf-mergetemplate --drop-old-templates @extraparams @trans $templates > $tmp/DEBIAN/templates");
chmod 0644, "$tmp/DEBIAN/templates";
chown 0, 0, "$tmp/DEBIAN/templates";
diff --git a/doc/TODO b/doc/TODO
index 99890c0f..b31dab89 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -47,3 +47,5 @@ Deprecated:
catches on, make it emit a warning, and then wait for it to go away.
* dh_testversion. Remove as soon as nothing uses it.
* dh_movefiles. I won't hold my breath.
+* debconf-mergetemplates support and the debian/template.ll files and the
+ debconf-utils dependency.