summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdh2
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 83ba2ea0..73f84804 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -20,6 +20,9 @@ debhelper (8.9.7) UNRELEASED; urgency=low
* Remove obsolete versioned dependency on perl-base.
* Avoid writing debhelper log files in no-act mode. Closes: #640586
* Tighten parsing of DEB_BUILD_OPTIONS.
+ * dh: Avoid running install sequence a third time in v9 when the
+ rules file has explicit binary-indep and binary-arch targets.
+ Closes: #639341 Thanks, Yann Dirson for test case.
-- Joey Hess <joeyh@debian.org> Mon, 29 Aug 2011 20:18:01 -0400
diff --git a/dh b/dh
index e6c7663e..dff7f25d 100755
--- a/dh
+++ b/dh
@@ -418,7 +418,7 @@ if (! compat(8)) {
$sequences{build} = [@bd_minimal, rules("build-arch"), rules("build-indep")];
$sequences{'install-indep'} = [rules("build-indep"), @i];
$sequences{'install-arch'} = [rules("build-arch"), @i];
- $sequences{'install'} = [rules("build"), rules("install-arch"), rules("install-indep"), @i];
+ $sequences{'install'} = [rules("build"), rules("install-arch"), rules("install-indep")];
$sequences{'binary-indep'} = [rules("install-indep"), @b];
$sequences{'binary-arch'} = [rules("install-arch"), @ba, @b];
$sequences{binary} = [rules("install"), rules("binary-arch"), rules("binary-indep")];