summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postinst-init2
-rw-r--r--autoscripts/postinst-init-norestart2
-rw-r--r--autoscripts/prerm-init2
-rw-r--r--autoscripts/prerm-init-norestart2
-rw-r--r--debian/changelog8
5 files changed, 12 insertions, 4 deletions
diff --git a/autoscripts/postinst-init b/autoscripts/postinst-init
index 5ef99c7c..159b12d7 100644
--- a/autoscripts/postinst-init
+++ b/autoscripts/postinst-init
@@ -1,4 +1,4 @@
-if [ -e "#SCRIPT#" ]; then
+if [ -e "/etc/init.d/#SCRIPT#" ]; then
update-rc.d #SCRIPT# #INITPARMS# >/dev/null
/etc/init.d/#SCRIPT# start
fi
diff --git a/autoscripts/postinst-init-norestart b/autoscripts/postinst-init-norestart
index d57bfc09..3445f149 100644
--- a/autoscripts/postinst-init-norestart
+++ b/autoscripts/postinst-init-norestart
@@ -1,4 +1,4 @@
-if [ -e "#SCRIPT#" ]; then
+if [ -e "/etc/init.d/#SCRIPT#" ]; then
update-rc.d #SCRIPT# #INITPARMS# >/dev/null
if [ "$1" = "configure" ]; then
if [ -z "$2" -o "$2" = "<unknown>" ]; then
diff --git a/autoscripts/prerm-init b/autoscripts/prerm-init
index 260d69d9..9ffa64b7 100644
--- a/autoscripts/prerm-init
+++ b/autoscripts/prerm-init
@@ -1,3 +1,3 @@
-if [ -e "#SCRIPT#" ]; then
+if [ -e "/etc/init.d/#SCRIPT#" ]; then
/etc/init.d/#SCRIPT# stop
fi
diff --git a/autoscripts/prerm-init-norestart b/autoscripts/prerm-init-norestart
index e04ec25a..47a49d4a 100644
--- a/autoscripts/prerm-init-norestart
+++ b/autoscripts/prerm-init-norestart
@@ -1,3 +1,3 @@
-if [ -e "#SCRIPT#" -a "$1" = remove ]; then
+if [ -e "/etc/init.d/#SCRIPT#" -a "$1" = remove ]; then
/etc/init.d/#SCRIPT# stop
fi
diff --git a/debian/changelog b/debian/changelog
index 4468a462..686bb497 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (3.0.10) unstable; urgency=medium
+
+ * Fixed broken -e #SCRIPT# tests in init script start/stop/restart code.
+ Arrgh. All packages built with the old code (that is, all daemon
+ packages built with debhelper 3.0.9!) are broken. Closes: #89472
+
+ -- Joey Hess <joeyh@debian.org> Tue, 13 Mar 2001 06:10:03 -0500
+
debhelper (3.0.9) unstable; urgency=low
* Modified to use dpkg-architecture instead of dpkg --print-architecture.