summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_clean2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 49edc1fb..0efaa3ee 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (5.0.58) UNRELEASED; urgency=low
+
+ * dh_clean: append "/" to the temp dir name to avoid removing
+ a file with the same name. Closes: #445638
+
+ -- Joey Hess <joeyh@debian.org> Sun, 07 Oct 2007 09:27:26 -0400
+
debhelper (5.0.57) unstable; urgency=low
* Add --ignore option. This is intended to ease dealing with upstream
diff --git a/dh_clean b/dh_clean
index 18c298df..21114df8 100755
--- a/dh_clean
+++ b/dh_clean
@@ -70,7 +70,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
complex_doit("rm -f debian/$ext*.debhelper");
}
- doit ("rm","-rf",$tmp)
+ doit ("rm","-rf",$tmp."/")
unless excludefile($tmp);
}