summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postinst-init2
-rw-r--r--autoscripts/postinst-init-norestart2
-rw-r--r--autoscripts/prerm-init2
-rw-r--r--autoscripts/prerm-init-norestart2
-rw-r--r--debian/changelog14
-rw-r--r--debian/control2
-rwxr-xr-xdh_clean22
-rw-r--r--doc/TODO8
8 files changed, 20 insertions, 34 deletions
diff --git a/autoscripts/postinst-init b/autoscripts/postinst-init
index 159b12d7..051f7747 100644
--- a/autoscripts/postinst-init
+++ b/autoscripts/postinst-init
@@ -1,4 +1,4 @@
-if [ -e "/etc/init.d/#SCRIPT#" ]; then
+if [ -x "/etc/init.d/#SCRIPT#" ]; then
update-rc.d #SCRIPT# #INITPARMS# >/dev/null
/etc/init.d/#SCRIPT# start
fi
diff --git a/autoscripts/postinst-init-norestart b/autoscripts/postinst-init-norestart
index 3445f149..4f1c63f9 100644
--- a/autoscripts/postinst-init-norestart
+++ b/autoscripts/postinst-init-norestart
@@ -1,4 +1,4 @@
-if [ -e "/etc/init.d/#SCRIPT#" ]; then
+if [ -x "/etc/init.d/#SCRIPT#" ]; then
update-rc.d #SCRIPT# #INITPARMS# >/dev/null
if [ "$1" = "configure" ]; then
if [ -z "$2" -o "$2" = "<unknown>" ]; then
diff --git a/autoscripts/prerm-init b/autoscripts/prerm-init
index 9ffa64b7..9882c7c0 100644
--- a/autoscripts/prerm-init
+++ b/autoscripts/prerm-init
@@ -1,3 +1,3 @@
-if [ -e "/etc/init.d/#SCRIPT#" ]; then
+if [ -x "/etc/init.d/#SCRIPT#" ]; then
/etc/init.d/#SCRIPT# stop
fi
diff --git a/autoscripts/prerm-init-norestart b/autoscripts/prerm-init-norestart
index 47a49d4a..b7e311d3 100644
--- a/autoscripts/prerm-init-norestart
+++ b/autoscripts/prerm-init-norestart
@@ -1,3 +1,3 @@
-if [ -e "/etc/init.d/#SCRIPT#" -a "$1" = remove ]; then
+if [ -x "/etc/init.d/#SCRIPT#" -a "$1" = remove ]; then
/etc/init.d/#SCRIPT# stop
fi
diff --git a/debian/changelog b/debian/changelog
index a569e78d..37becd64 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,13 @@
-debhelper (3.0.41) unstable; urgency=low
+debhelper (3.0.42) unstable; urgency=low
- * Clean up old substvars.debhelper files, although debhelper doesn't
- generate them now, it used to and they may still be lurking in build
- trees. Closes: #106514
- * Fixed a typo. Closes: #106532
+ * dh_movefiles: Typo, Closes: #106532
+ * Use -x to test for existance of init scripts, rather then -e since
+ we'll be running them, Closes: #109692
+ * dh_clean: remove debian/*.debhelper. No need to name files
+ specifically; any file matching that is a debhelper temp file.
+ Closes: #106514, #85520
- -- Joey Hess <joeyh@debian.org> Wed, 25 Jul 2001 17:04:21 -0400
+ -- Joey Hess <joeyh@debian.org> Thu, 23 Aug 2001 15:47:35 -0400
debhelper (3.0.40) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 2f9d0bbf..8eb36668 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
Build-Depends-Indep: perl, fileutils (>= 4.0-2.1), file (>= 3.23-1), debconf-utils
-Standards-Version: 3.2.1.0
+Standards-Version: 3.5.6.0
Package: debhelper
Architecture: all
diff --git a/dh_clean b/dh_clean
index 570179b9..388f913c 100755
--- a/dh_clean
+++ b/dh_clean
@@ -18,8 +18,8 @@ use Debian::Debhelper::Dh_Lib;
dh_clean is a debhelper program that is responsible for cleaning up after a
package is built. It removes the package build directories, and removes some
other files, such as debian/substvars, debian/files, and any detritus left
-behind by other debhelper commands. It also removes common files that
-should not appear in a debian diff:
+behind by other debhelper commands (debian/*.debhelper). It also removes
+common files that should not appear in a debian diff:
#*# *~ DEADJOE *.orig *.rej *.SUMS TAGS core .deps/* *.P
=head1 OPTIONS
@@ -62,12 +62,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my $ext=pkgext($package);
if (! $dh{D_FLAG}) {
- doit("rm","-f","debian/${ext}substvars",
- "debian/${ext}substvars.debhelper",
- "debian/${ext}postinst.debhelper",
- "debian/${ext}postrm.debhelper",
- "debian/${ext}preinst.debhelper",
- "debian/${ext}prerm.debhelper");
+ doit("rm","-f","debian/${ext}substvars");
}
doit ("rm","-rf",$tmp);
@@ -82,14 +77,9 @@ if (! $dh{D_FLAG}) {
doit("rm","-f","debian/files");
}
- # Remove some files that were left around by older versions of
- # debhelper, just in case someone upgrades in the middle of a
- # build.
- doit("rm","-f","debian/substvars",
- "debian/postinst.debhelper",
- "debian/postrm.debhelper",
- "debian/preinst.debhelper",
- "debian/prerm.debhelper");
+ # These are all debhelper temp files, and so it is safe to
+ # wildcard them.
+ complex_doit("rm -f debian/*.debhelper");
# See if some files that would normally be deleted are excluded.
my $find_options='';
diff --git a/doc/TODO b/doc/TODO
index eb12909c..bdc6fe99 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -40,10 +40,6 @@ Wishlist items:
* All programs should also make sure the files they install are owned by
root.root. Situation is currently the same as with permissions above, plus
dh_installchangelogs is fixed.
-* Need a way to make dh_strip not strip any static libs. Also, it'd be nice
- if there were options to dh_strip, dh_compress, etc, to allow inclusion of
- directories and exclusion of files based on filename globbing. (Request from
- Matthias Klose <doko@cs.tu-berlin.de>)
* Support use of environment variables in data taken from user, ie, in
debian/dirs. The problem with doing this is that we really want to allow
any filenames in that input, even those that look like environment
@@ -53,12 +49,10 @@ Wishlist items:
multiple commands call. One way to do this would be to write dh_cache,
that generates the cache. The catch is that if the user runs that program,
they are stating that they don't do anything later to invalidate the cache,
- without calling ch_cache again. (#23792)
+ without calling dh_cache again. (#23792)
* Add a switch to dh_installdeb to allow it to do user defined
substitutions. OTOH, maybe it's better if people just sed
postinst.in before debhelper gets it's hands on it... (#25235)
-* objdump -p can get the soname of a library, try using that in dh_shlibs
- instead of parsing filenames.
Deprecated: