summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rwxr-xr-xdh_installchangelogs11
2 files changed, 12 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 4e3dffd0..8cdf1185 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-debhelper (7.2.3) UNRELEASED; urgency=low
+debhelper (7.2.3-1) UNRELEASED; urgency=low
* dh_installmenus: Now that a triggers capable menu and dpkg are in
stable, menu does not need to be explicitly run in maintainer
@@ -6,6 +6,8 @@ debhelper (7.2.3) UNRELEASED; urgency=low
* dh_installdocs: No longer add maintainer script code to call
doc-base, as it supports triggers in stable.
* dh: Override LC_ALL, not LANG. Closes: #517617
+ * dh_installchangelogs: Support -X to exclude automatic installation
+ of specific upstream changelogs. Closes: #490937
-- Joey Hess <joeyh@debian.org> Fri, 06 Mar 2009 13:57:47 -0500
diff --git a/dh_installchangelogs b/dh_installchangelogs
index a5cce3f4..3749d523 100755
--- a/dh_installchangelogs
+++ b/dh_installchangelogs
@@ -11,7 +11,7 @@ use Debian::Debhelper::Dh_Lib;
=head1 SYNOPSIS
-B<dh_installchangelogs> [S<I<debhelper options>>] [B<-k>] [I<upstream>]
+B<dh_installchangelogs> [S<I<debhelper options>>] [B<-k>] [B<-X>I<item>] [I<upstream>]
=head1 DESCRIPTION
@@ -53,6 +53,11 @@ that to the original name of the changelog file. This can be useful if the
upstream changelog has an unusual name, or if other documentation in the
package refers to the changelog file.
+=item B<-Xitem>, B<--exclude=item>
+
+Exclude upstream changelog files that contain "item" anywhere in their
+filename from being installed.
+
=item I<upstream>
Install this file as the upstream changelog.
@@ -69,7 +74,9 @@ if (! defined $upstream) {
if (! isnative($dh{MAINPACKAGE}) && !compat(6)) {
my @files=sort glob("*");
foreach my $name (qw{changelog changes changelog.txt changes.txt}) {
- my @matches=grep { lc $_ eq $name && -s $_ } @files;
+ my @matches=grep {
+ lc $_ eq $name && -s $_ && ! excludefile($_)
+ } @files;
if (@matches) {
$upstream=shift @matches;
last;