summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Lib.pm6
-rw-r--r--debhelper.pod6
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_installdocs2
-rwxr-xr-xdh_installmanpages2
-rwxr-xr-xdh_installwm2
-rwxr-xr-xdh_makeshlibs6
-rwxr-xr-xdh_movefiles2
-rw-r--r--doc/PROGRAMMING4
9 files changed, 21 insertions, 15 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 92eae0c7..4beaa0dc 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -209,7 +209,7 @@ sub dirname {
return $fn;
}
-# Pass in a number, will return true iff the current compatability level
+# Pass in a number, will return true iff the current compatibility level
# is less than or equal to that number.
sub compat {
my $num=shift;
@@ -220,7 +220,7 @@ sub compat {
}
if ($c > $max_compat) {
- error("Sorry, but $max_compat is the highest compatability level of debhelper currently supported.");
+ error("Sorry, but $max_compat is the highest compatibility level of debhelper currently supported.");
}
return ($c <= $num);
@@ -235,7 +235,7 @@ sub tmpdir {
return $dh{TMPDIR};
}
elsif (compat(1) && $package eq $dh{MAINPACKAGE}) {
- # This is for back-compatability with the debian/tmp tradition.
+ # This is for back-compatibility with the debian/tmp tradition.
return "debian/tmp";
}
else {
diff --git a/debhelper.pod b/debhelper.pod
index a93034e5..85b3fd29 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -194,7 +194,7 @@ you have a package that builds many binary packages, you will need to also
use the -p flag to specify which binary package the debhelper program will
act on.
-=head2 Debhelper compatability levels
+=head2 Debhelper compatibility levels
From time to time, major non-backwards-compatible changes need to be made
to debhelper, to keep it clean and well-designed as needs change and its
@@ -208,7 +208,7 @@ debhelper should be used. There are currently 3:
=item V1
Setting DH_COMPAT=1 (or leaving it unset) causes debhelper to act in
-compatability mode. It will use debian/tmp as the package tree
+compatibility mode. It will use debian/tmp as the package tree
directory for the first binary package listed in the control file, while using
debian/<package> for all other packages listed in the control file.
This mode is deprecated.
@@ -282,7 +282,7 @@ that modifies files on the build system.
=item DH_COMPAT
-Specifies what compatability level debhelper should run at. See above.
+Specifies what compatibility level debhelper should run at. See above.
=item DH_NO_ACT
diff --git a/debian/changelog b/debian/changelog
index 44948daa..2d2d8e05 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (3.0.37) unstable; urgency=low
+
+ * Spellpatch, Closes: #101553
+
+ -- Joey Hess <joeyh@debian.org> Wed, 20 Jun 2001 22:03:57 -0400
+
debhelper (3.0.36) unstable; urgency=low
* Whoops, I forgot to revert dh_perl too. Closes: #101477
diff --git a/dh_installdocs b/dh_installdocs
index 621c5c0f..a6304530 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -153,7 +153,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
}
- # Add in the /usr/doc compatability symlinks code.
+ # Add in the /usr/doc compatibility symlinks code.
if (! $dh{NOSCRIPTS}) {
autoscript($package,"postinst","postinst-doc",
"s/#PACKAGE#/$package/g",
diff --git a/dh_installmanpages b/dh_installmanpages
index 60dcd832..cbde23c3 100755
--- a/dh_installmanpages
+++ b/dh_installmanpages
@@ -142,7 +142,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my $install=1;
foreach my $skip (@ARGV) {
# Look at basename of what's on connect line
- # for backwards compatability.
+ # for backwards compatibility.
if ($basename eq basename($skip)) {
$install=undef;
last;
diff --git a/dh_installwm b/dh_installwm
index 842b4f4c..6199c0ac 100755
--- a/dh_installwm
+++ b/dh_installwm
@@ -63,7 +63,7 @@ if (! defined $dh{PRIORITY}) {
}
if (@ARGV) {
- # This is here for backwards compatability. If the filename doesn't
+ # This is here for backwards compatibility. If the filename doesn't
# include a path, assume it's in /usr/X11R6/bin.
if ($ARGV[0] !~ m:/:) {
$ARGV[0]="/usr/X11R6/bin/$ARGV[0]";
diff --git a/dh_makeshlibs b/dh_makeshlibs
index a70d3b22..1e5dd797 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -42,9 +42,9 @@ depend on any particular version of the package containing the shared
library. It may be necessary for you to add some version dependancy
information to the shlibs file. If -V is specified with no dependancy
information, the current version of the package is plugged into a
-dependancy that looks like "packagename (>= packageversion)". If -V is specified with
-parameters, the parameters can be used to specify the exact dependancy
-information needed (be sure to include the package name).
+dependancy that looks like "packagename (>= packageversion)". If -V is
+specified with parameters, the parameters can be used to specify the exact
+dependancy information needed (be sure to include the package name).
=item B<-n>, B<--noscripts>
diff --git a/dh_movefiles b/dh_movefiles
index 3fc689f6..18e46d4d 100755
--- a/dh_movefiles
+++ b/dh_movefiles
@@ -50,7 +50,7 @@ tell dh_movefiles which subpackage to put them in.
=head1 NOTES
Note that files are always moved out of debian/tmp by default (even if you
-have instructed debhelper to use a compatability level higher than one,
+have instructed debhelper to use a compatibility level higher than one,
which does not otherwise use debian/tmp for anything at all). The idea
behind this is that the package that is being built can be told to install
into debian/tmp, and then files can be moved by dh_movefiles from that
diff --git a/doc/PROGRAMMING b/doc/PROGRAMMING
index 0934727e..a1fa8ee7 100644
--- a/doc/PROGRAMMING
+++ b/doc/PROGRAMMING
@@ -178,9 +178,9 @@ tmpdir()
name of the tmp directory that will be used as this package's
package build directory. Typically, this will be "debian/package".
compat()
- Pass this command a number, and if the current compatability level
+ Pass this command a number, and if the current compatibility level
equals that number, it will return true. Looks at DH_COMPAT to get
- the compatability level.
+ the compatibility level.
pkgfile()
Pass this command the name of a binary package, and the base name of a
file, and it will return the actual filename to use. This is used