summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog9
-rw-r--r--debian/control4
-rwxr-xr-xdh_clean1
-rwxr-xr-xdh_movefiles2
4 files changed, 13 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 1f988bef..a569e78d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+debhelper (3.0.41) unstable; urgency=low
+
+ * Clean up old substvars.debhelper files, although debhelper doesn't
+ generate them now, it used to and they may still be lurking in build
+ trees. Closes: #106514
+ * Fixed a typo. Closes: #106532
+
+ -- Joey Hess <joeyh@debian.org> Wed, 25 Jul 2001 17:04:21 -0400
+
debhelper (3.0.40) unstable; urgency=low
* Typo, Closes: #104405
diff --git a/debian/control b/debian/control
index 9516be33..2f9d0bbf 100644
--- a/debian/control
+++ b/debian/control
@@ -2,8 +2,8 @@ Source: debhelper
Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
-Build-Depends-Indep: perl-5.6, fileutils (>= 4.0-2.1), file (>= 3.23-1), debconf-utils
-Standards-Version: 3.5.5.0
+Build-Depends-Indep: perl, fileutils (>= 4.0-2.1), file (>= 3.23-1), debconf-utils
+Standards-Version: 3.2.1.0
Package: debhelper
Architecture: all
diff --git a/dh_clean b/dh_clean
index d86743a5..570179b9 100755
--- a/dh_clean
+++ b/dh_clean
@@ -63,6 +63,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (! $dh{D_FLAG}) {
doit("rm","-f","debian/${ext}substvars",
+ "debian/${ext}substvars.debhelper",
"debian/${ext}postinst.debhelper",
"debian/${ext}postrm.debhelper",
"debian/${ext}preinst.debhelper",
diff --git a/dh_movefiles b/dh_movefiles
index 18e46d4d..b4e1a6f6 100755
--- a/dh_movefiles
+++ b/dh_movefiles
@@ -91,7 +91,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
if (@tomove && $tmp eq $sourcedir) {
- error("I was asked to move files from $sourcedir to $sourcedir. Perhaps you should set DH_COMAPT=2?");
+ error("I was asked to move files from $sourcedir to $sourcedir. Perhaps you should set DH_COMPAT=2?");
}
# Now we need to expand wildcards in @tomove.