summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Buildsystems.pm2
-rw-r--r--debhelper.pod17
-rw-r--r--debian/changelog3
3 files changed, 14 insertions, 8 deletions
diff --git a/Debian/Debhelper/Dh_Buildsystems.pm b/Debian/Debhelper/Dh_Buildsystems.pm
index f6c123c5..dd12ee95 100644
--- a/Debian/Debhelper/Dh_Buildsystems.pm
+++ b/Debian/Debhelper/Dh_Buildsystems.pm
@@ -136,7 +136,7 @@ sub load_all_buildsystems {
sub buildsystems_init {
my %args=@_;
- my $max_parallel=-1; # unlimited
+ my $max_parallel=1;
# Available command line options
my %options = (
diff --git a/debhelper.pod b/debhelper.pod
index 98aa422c..29687adc 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -219,14 +219,17 @@ directory path that is the same as the source directory path.
=item B<--max-parallel>I<=maximum>
-By default, the DEB_BUILD_OPTIONS environment variable can be used to
-enable parallel building, when supported by the build system.
-
This option allows controlling how many parallel jobs can be used in a
-build. If set to 1, concurrent builds are disabled -- do this if
-the package build is known not to work in parallel. If the package build
-is known to only work with certian levels of concurrency, you can set this
-to the maximum level that is known to work, or that you wish to support.
+build, if parallel builds are enabled by the DEB_BUILD_OPTIONS environment
+variable.
+
+If set to 1, parallel builds are disabled -- do this if the package build
+is known not to work in parallel. If the package build is known to only
+work with certian levels of concurrency, you can set this to the maximum
+level that is known to work, or that you wish to support.
+
+If this option is not specified, debhelper currently defaults to not
+supporting parallel package builds.
=item B<--list>, B<-l>
diff --git a/debian/changelog b/debian/changelog
index 141920e5..c3aeafb5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,8 @@
debhelper (7.4.8) UNRELEASED; urgency=low
+ * Parallel building support is no longer enabled by default. It can still
+ be enabled by using the --max-parallel option. This was necessary because
+ some buildds build with -j2 by default.
* dh: Document --no-act. Closes: #557505
* dh_makeshlibs: Make -X also exclude libraries from the symbols file.
Closes: #557603 (Peter Samuelson)