summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/autoconf.pm3
-rw-r--r--debhelper.pod4
-rw-r--r--debian/changelog2
3 files changed, 7 insertions, 2 deletions
diff --git a/Debian/Debhelper/Buildsystem/autoconf.pm b/Debian/Debhelper/Buildsystem/autoconf.pm
index 20b9fd44..56a42887 100644
--- a/Debian/Debhelper/Buildsystem/autoconf.pm
+++ b/Debian/Debhelper/Buildsystem/autoconf.pm
@@ -37,6 +37,9 @@ sub configure {
push @opts, "--infodir=\${prefix}/share/info";
push @opts, "--sysconfdir=/etc";
push @opts, "--localstatedir=/var";
+ if (defined $ENV{DH_VERBOSE} && $ENV{DH_VERBOSE} ne "") {
+ push @opts, "--disable-silent-rules";
+ }
my $multiarch=dpkg_architecture_value("DEB_HOST_MULTIARCH");
if (! compat(8)) {
if (defined $multiarch) {
diff --git a/debhelper.pod b/debhelper.pod
index e1cff777..23f85829 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -651,8 +651,8 @@ F<preinst>, F<postrm>, F<prerm>, and F<config> scripts, etc.
=item B<DH_VERBOSE>
-Set to B<1> to enable verbose mode. Debhelper will output every command it runs
-that modifies files on the build system.
+Set to B<1> to enable verbose mode. Debhelper will output every command it
+runs. Also enables verbose build logs for some build systems like autoconf.
=item B<DH_COMPAT>
diff --git a/debian/changelog b/debian/changelog
index a93c8b93..585c82d6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,7 @@
debhelper (9.20140229) UNRELEASED; urgency=medium
+ * Pass --disable-silent-rules in dh_auto_configure if DH_VERBOSE is set.
+ Closes: #751207. Thanks, Helmut Grohne.
* Minor typos. Closes: #741144, #744176
* dh_installinit: Fix uninitialized value warning when --name is used.