summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_shlibdeps14
2 files changed, 18 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index e9809d28..6a637396 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.2.25) unstable; urgency=low
+
+ * dh_shlibdeps: Only set LD_LIBRARY_PATH when calling dpkg-shlibdeps.
+ Closes: #283413
+
+ -- Joey Hess <joeyh@debian.org> Mon, 29 Nov 2004 13:21:05 -0500
+
debhelper (4.2.24) unstable; urgency=low
* Spanish man page updates.
diff --git a/dh_shlibdeps b/dh_shlibdeps
index 54c42ce1..77d8d6a9 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -80,7 +80,6 @@ information.
init();
-# Add directory to library search path.
if ($dh{L_PARAMS}) {
my @paths=();
# Add to existing paths, if set.
@@ -96,8 +95,6 @@ if ($dh{L_PARAMS}) {
}
}
$dh{L_PARAMS}=join(':', @paths);
- $ENV{'LD_LIBRARY_PATH'}=$dh{L_PARAMS};
- verbose_print("LD_LIBRARY_PATH=$dh{L_PARAMS}");
}
foreach my $package (@{$dh{DOPACKAGES}}) {
@@ -127,8 +124,19 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (defined $dh{LIBPACKAGE} && length $dh{LIBPACKAGE}) {
@opts=("-L".tmpdir($dh{LIBPACKAGE}."/DEBIAN/shlibs"));
}
+
+ my $ld_library_path_orig=$ENV{LD_LIBRARY_PATH};
+ if ($dh{L_PARAMS}) {
+ $ENV{LD_LIBRARY_PATH}=$dh{L_PARAMS};
+ verbose_print("LD_LIBRARY_PATH=$dh{L_PARAMS}");
+ }
+
doit("dpkg-shlibdeps","-Tdebian/${ext}substvars",
@opts,@{$dh{U_PARAMS}},@filelist);
+
+ if ($dh{L_PARAMS}) {
+ $ENV{LD_LIBRARY_PATH}=$ld_library_path_orig;
+ }
}
}