summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/makefile.pm4
-rw-r--r--debian/changelog4
2 files changed, 6 insertions, 2 deletions
diff --git a/Debian/Debhelper/Buildsystem/makefile.pm b/Debian/Debhelper/Buildsystem/makefile.pm
index c63b58ed..8d0def15 100644
--- a/Debian/Debhelper/Buildsystem/makefile.pm
+++ b/Debian/Debhelper/Buildsystem/makefile.pm
@@ -20,7 +20,7 @@ sub exists_make_target {
unshift @opts, "-C", $buildpath if $buildpath ne ".";
open(SAVEDERR, ">&STDERR");
open(STDERR, ">/dev/null");
- open(MAKE, "-|", $this->{makecmd}, @opts, $target);
+ open(MAKE, "-|", $this->{makecmd}, @opts, $target, @_);
my $output=<MAKE>;
chomp $output;
close MAKE;
@@ -46,7 +46,7 @@ sub make_first_existing_target {
my $targets=shift;
foreach my $target (@$targets) {
- if ($this->exists_make_target($target)) {
+ if ($this->exists_make_target($target, @_)) {
$this->do_make($target, @_);
return $target;
}
diff --git a/debian/changelog b/debian/changelog
index 55f764f8..d27015c0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,10 @@ debhelper (9.20130505) UNRELEASED; urgency=low
Closes: #705141
* dh_installdeb: Drop pre-dependency on dpkg for dpkg-maintscript-helper.
Closes: #703264
+ * makefile buildsystem: Pass any parameters specified after -- when
+ running make -n to test for the existance of targets.
+ In some makefiles, the parameters may be necessary to enable a target.
+ Closes: #706923
-- Joey Hess <joeyh@debian.org> Sun, 05 May 2013 11:34:20 -0400