summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog12
-rwxr-xr-xdh_clean9
2 files changed, 17 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 26085f6c..e1a1e626 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+debhelper (8.1.4) UNRELEASED; urgency=low
+
+ * dh_clean: Remove debhelper logs for all packages, including packages
+ not being acted on. dh can sometimes produce such logs by accident
+ when passed bundled options (like "-Nfoo" instead of "-N foo") that
+ it does not understand; and it was not possible to fix that
+ for any compat level before v8. But also, such logs can occur
+ for other reasons, like interrupted builds during development,
+ and it should be safe to clean them all. Closes: #623446
+
+ -- Joey Hess <joeyh@debian.org> Thu, 21 Apr 2011 14:05:52 -0400
+
debhelper (8.1.3) unstable; urgency=low
[ Joey Hess ]
diff --git a/dh_clean b/dh_clean
index dc29e36f..c18f7686 100755
--- a/dh_clean
+++ b/dh_clean
@@ -86,16 +86,17 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# These are all debhelper temp files, and so it is safe to
# wildcard them.
complex_doit("rm -f debian/$ext*.debhelper");
-
- if (! $dh{K_FLAG}) {
- doit("rm","-f","debian/${ext}debhelper.log");
- }
}
doit ("rm","-rf",$tmp."/")
unless excludefile($tmp);
}
+# Remove all debhelper logs.
+if (! $dh{D_FLAG} && ! $dh{K_FLAG}) {
+ complex_doit("rm","-f","debian/*.debhelper.log");
+}
+
if (! $dh{D_FLAG}) {
if (@ARGV) {
doit("rm","-f","--",@ARGV);