summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/autoconf.pm7
-rw-r--r--debian/control2
-rwxr-xr-xdh_makeshlibs2
3 files changed, 6 insertions, 5 deletions
diff --git a/Debian/Debhelper/Buildsystem/autoconf.pm b/Debian/Debhelper/Buildsystem/autoconf.pm
index 10599d14..c211d8da 100644
--- a/Debian/Debhelper/Buildsystem/autoconf.pm
+++ b/Debian/Debhelper/Buildsystem/autoconf.pm
@@ -37,9 +37,10 @@ sub configure {
push @opts, "--infodir=\${prefix}/share/info";
push @opts, "--sysconfdir=/etc";
push @opts, "--localstatedir=/var";
- if (! compat(8)) {
- push @opts, "--libdir=\${prefix}/lib/" . dpkg_architecture_value("DEB_HOST_MULTIARCH");
- push @opts, "--libexecdir=\${prefix}/lib/" . dpkg_architecture_value("DEB_HOST_MULTIARCH") . "/" . sourcepackage();
+ my $multiarch=dpkg_architecture_value("DEB_HOST_MULTIARCH");
+ if (! compat(8) && defined $multiarch) {
+ push @opts, "--libdir=\${prefix}/lib/$multiarch";
+ push @opts, "--libexecdir=\${prefix}/lib/$multiarch/" . sourcepackage();
}
else {
push @opts, "--libexecdir=\${prefix}/lib/" . sourcepackage();
diff --git a/debian/control b/debian/control
index 202f4180..cdf7489c 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,7 @@ Homepage: http://kitenet.net/~joey/code/debhelper/
Package: debhelper
Architecture: all
-Depends: ${perl:Depends}, ${misc:Depends}, perl-base (>= 5.10), file (>= 3.23), dpkg-dev (>= 1.16.0), html2text, binutils, po-debconf, man-db (>= 2.5.1-1)
+Depends: ${perl:Depends}, ${misc:Depends}, perl-base (>= 5.10), file (>= 3.23), dpkg-dev (>= 1.14.19), html2text, binutils, po-debconf, man-db (>= 2.5.1-1)
Suggests: dh-make
Conflicts: dpkg-cross (<< 1.18), python-support (<< 0.5.3), python-central (<< 0.5.6)
Description: helper programs for debian/rules
diff --git a/dh_makeshlibs b/dh_makeshlibs
index 5d6f869c..896c5b3e 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -150,7 +150,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
while (<FIND>) {
my ($library, $major);
push @lib_files, $_;
- if ($multiarch ne '' && $_ =~ m,/$multiarch/,) {
+ if (defined $multiarch && $multiarch ne '' && m,/$multiarch/,) {
$is_multiarch=1;
}
my $ret=`$objdump -p $_`;