summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rw-r--r--debian/control2
-rwxr-xr-xdh_shlibdeps15
3 files changed, 16 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 6fd992dc..a68b8fcf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,10 @@ debhelper (5.0.64) UNRELEASED; urgency=low
to it, instead just prepend a slash to make it absolute. dpkg-shlibdeps
has changed how it used LD_LIBRARY_PATH, so making it point into the
package build directory won't work.
+ * dh_shlibdeps: Change "-L pkg" to cause "-Sdebian/pkg" to be passed to
+ dpkg-shlibdeps. The old behavior of passing -L to dpkg-shlibdeps didn't
+ affect where it looked for symbols files. Closes: #459224
+ * Depend on dpkg-dev 1.14.15, the first to support dpkg-shlibdeps -S.
-- Joey Hess <joeyh@debian.org> Fri, 28 Dec 2007 15:45:39 -0500
diff --git a/debian/control b/debian/control
index fcc75066..edfe59f8 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Homepage: http://kitenet.net/~joey/code/debhelper/
Package: debhelper
Architecture: all
-Depends: ${perl:Depends}, ${misc:Depends}, coreutils, file (>= 3.23-1), dpkg-dev (>= 1.14.12), html2text, binutils, po-debconf
+Depends: ${perl:Depends}, ${misc:Depends}, coreutils, file (>= 3.23-1), dpkg-dev (>= 1.14.15), html2text, binutils, po-debconf
Suggests: dh-make
Conflicts: dpkg-cross (<< 1.18), python-support (<< 0.5.3), python-central (<< 0.5.6)
Description: helper programs for debian/rules
diff --git a/dh_shlibdeps b/dh_shlibdeps
index cfbfa2de..a076537a 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -55,10 +55,11 @@ path.
=item B<-L>I<package>, B<--libpackage=>I<package>
With recent versions of dpkg-shlibdeps, this option is generally not
-needed.
+needed, unless your package builds multiple flavors of the same library.
-Tell dpkg-shlibdeps to use the shlibs file automatically generated by
-dh_makeshlibs for the named package instead of the shlibs.local file.
+It tells dpkg-shlibdeps (via its -S parameter) to look first in the package
+build directory for the specified package, when searching for libraries,
+symbol files, and shlibs files.
=back
@@ -76,6 +77,12 @@ libfoo1, and using that file and the libfoo1 library in the
debian/libfoo1/usr/lib directory to calculate shared library dependency
information.
+If a libbar1 package is also produced, that is an alternate build of
+libfoo, and is installed into /usr/lib/bar/, you can make libfoo-bin depend
+on libbar1 as follows:
+
+ dh_shlibdeps -Llibbar1 -l/usr/lib/bar
+
=cut
init();
@@ -122,7 +129,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (@filelist) {
my @opts;
if (defined $dh{LIBPACKAGE} && length $dh{LIBPACKAGE}) {
- @opts=("-L".tmpdir($dh{LIBPACKAGE}."/DEBIAN/shlibs"));
+ @opts=("-S".tmpdir($dh{LIBPACKAGE}));
}
push @opts, "-tudeb" if is_udeb($package);