summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Lib.pm8
-rw-r--r--debian/changelog4
2 files changed, 11 insertions, 1 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index c72e559f..80f56387 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -656,6 +656,10 @@ sub getpackages {
sub package_arch {
my $package=shift;
+ if (! exists $package_arches{$package}) {
+ warning "package $package is not in control info";
+ return buildarch();
+ }
return $package_arches{$package} eq 'all' ? "all" : buildarch();
}
@@ -663,6 +667,10 @@ sub package_arch {
sub is_udeb {
my $package=shift;
+ if (! exists $package_types{$package}) {
+ warning "package $package is not in control info";
+ return 0;
+ }
return $package_types{$package} eq 'udeb';
}
diff --git a/debian/changelog b/debian/changelog
index 4c036d15..8a72f9b7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,8 +3,10 @@ debhelper (5.0.50) UNRELEASED; urgency=low
* dh_installwm: If a path is not given, assume the file is in usr/bin, since
usr/X11R6/bin now points to there.
* Update urls to web page.
+ * Add some checks for attempts to act on packages not defined in the control
+ file.
- -- Joey Hess <joeyh@debian.org> Thu, 17 May 2007 00:17:43 -0400
+ -- Joey Hess <joeyh@debian.org> Sun, 27 May 2007 22:27:59 -0400
debhelper (5.0.49) unstable; urgency=low