summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm10
-rw-r--r--debian/changelog9
2 files changed, 10 insertions, 9 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 4e98226d..e1b1aef0 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -90,11 +90,11 @@ sub dbg_build_needed {
# built in a clean chroot.
my @dbg;
- open (CONTROL, $this->get_sourcepath('debian/control')) ||
+ open (CONTROL, 'debian/control') ||
error("cannot read debian/control: $!\n");
foreach my $builddeps (join('', <CONTROL>) =~
/^Build-Depends[^:]*:.*\n(?:^[^\w\n].*\n)*/gmi) {
- foreach ($builddeps =~ /(python[^, ]*-dbg)/g) {
+ while ($builddeps =~ /(python[^, ]*-dbg)/g) {
push @dbg, $1;
}
}
@@ -120,8 +120,8 @@ sub setup_py {
$python_default =~ s/^\s+//;
$python_default =~ s/\s+$//;
my @python_requested = split ' ', `pyversions -r 2>/dev/null`;
- if (grep /^$python_default/, @python_requested) {
- @python_requested = ("python", grep(!/^$python_default/,
+ if (grep /^\Q$python_default\E/, @python_requested) {
+ @python_requested = ("python", grep(!/^\Q$python_default\E/,
@python_requested));
}
my @dbg_build_needed = $this->dbg_build_needed();
@@ -131,7 +131,7 @@ sub setup_py {
$this->doit_in_sourcedir($python, "setup.py", $act, @_);
}
$python = $python . "-dbg";
- if (grep /^(python-all-dbg|$python)/, @dbg_build_needed) {
+ if (grep /^(python-all-dbg|\Q$python\E)/, @dbg_build_needed) {
$this->doit_in_sourcedir($python, "setup.py", $act, @_);
} elsif (($python eq "python-dbg")
and (grep /^$python_default/, @dbg_build_needed)) {
diff --git a/debian/changelog b/debian/changelog
index dd75a83f..ad1b6c69 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,11 @@
debhelper (7.3.5) experimental; urgency=low
+ [ Bernd Zeimetz ]
* python_distutils buildsystem: Build for all supported Python
- versions in case they're installed. Ensure that correct
- shebangs are created by using `python' first during build
- and install. Closes: #520834
- Also build with python*-dbg in case the package build-depends
+ versions that are installed. Ensure that correct shebangs are
+ created by using `python' first during build and install.
+ Closes: #520834
+ Also build with python*-dbg if the package build-depends
on them.
-- Bernd Zeimetz <bzed@debian.org> Sun, 19 Jul 2009 15:26:13 +0200