summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm8
1 files changed, 5 insertions, 3 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 69032d21..e1b1aef0 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -131,10 +131,12 @@ sub setup_py {
$this->doit_in_sourcedir($python, "setup.py", $act, @_);
}
$python = $python . "-dbg";
- if ((grep /^(python-all-dbg|\Q$python\E)/, @dbg_build_needed)
- or (($python eq "python-dbg") and
- (grep /^$python_default/, @dbg_build_needed))) {
+ if (grep /^(python-all-dbg|\Q$python\E)/, @dbg_build_needed) {
$this->doit_in_sourcedir($python, "setup.py", $act, @_);
+ } elsif (($python eq "python-dbg")
+ and (grep /^$python_default/, @dbg_build_needed)) {
+ $this->doit_in_sourcedir($python_default."-dbg",
+ "setup.py", $act, @_);
}
}
}