summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog9
-rwxr-xr-xdh_python5
-rwxr-xr-xt/dh_link4
3 files changed, 10 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 42a80213..48bf2090 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,10 @@
-debhelper (4.2.37) unstable; urgency=low
+debhelper (4.2.38) UNRELEASED; urgency=low
* Document getpackages in PROGRAMMING.
- * Patch from Jeff Bailey to make dh_python set $python_version if -V is
- specified so it looks in the right site-packages directories.
- Closes: #312661
+ * Add another test-case for dh_link.
+ * dh_python: Minimal fix from Joss for -V to make it search the right
+ site-packages directories. Closes: #312661
+ *
-- Joey Hess <joeyh@debian.org> Thu, 9 Jun 2005 10:01:20 -0400
diff --git a/dh_python b/dh_python
index 3bd2ac7a..6a1f78f1 100755
--- a/dh_python
+++ b/dh_python
@@ -96,7 +96,6 @@ foreach (@python_allversions) {
# Check for -V
my $usepython = "python$python_version";
if($dh{V_FLAG_SET}) {
- $python_version = $dh{V_FLAG};
$usepython = $dh{V_FLAG};
$usepython =~ s/^/python/;
if (! grep { $_ eq $usepython } @python_allversions) {
@@ -140,8 +139,8 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
}
if ($package !~ /^python[0-9].[0-9]-/) {
- push @dirs, "usr/lib/python$python_version/site-packages" ;
- push @dirs_so, "usr/lib/python$python_version/site-packages" ;
+ push @dirs, "usr/lib/$usepython/site-packages";
+ push @dirs_so, "usr/lib/$usepython/site-packages";
$look_for_pythonXY = 0;
}
diff --git a/t/dh_link b/t/dh_link
index 68c7d4e5..198b522c 100755
--- a/t/dh_link
+++ b/t/dh_link
@@ -1,6 +1,6 @@
#!/usr/bin/perl
use Test;
-plan(tests => 7);
+plan(tests => 8);
# It used to not make absolute links in this situation, and it should.
# #37774
@@ -10,6 +10,8 @@ ok(readlink("debian/debhelper/usr/lib/bar"), "/etc/foo");
# let's make sure it makes simple relative links ok.
system("./dh_link","usr/bin/foo","usr/bin/bar");
ok(readlink("debian/debhelper/usr/bin/bar"), "foo");
+system("./dh_link","sbin/foo","sbin/bar");
+ok(readlink("debian/debhelper/sbin/bar"), "foo");
# ok, more complex relative links.
system("./dh_link","usr/lib/1","usr/bin/2");