summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog13
-rwxr-xr-xdh_install10
2 files changed, 15 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index a28a4839..082b0d13 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -29,6 +29,17 @@ debhelper (7.3.0) UNRELEASED; urgency=low
-- Joey Hess <joeyh@debian.org> Mon, 20 Apr 2009 16:26:08 -0400
+debhelper (7.2.19) unstable; urgency=low
+
+ * dh_install: Handle correctly the case where a glob expands to
+ a dangling symlink, installing the dangling link as requested.
+ Closes: #534565
+ * dh_install: Fix fallback use of debian/tmp in v7 mode; a bug caused
+ it to put files inside a debian/tmp directory in the package build
+ directory, now that prefix is stripped. (See #534565)
+
+ -- Joey Hess <joeyh@debian.org> Tue, 30 Jun 2009 12:56:52 -0400
+
debhelper (7.2.18) unstable; urgency=low
* dh_shlibdeps: Ensure DEBIAN directory exists, as dpkg-shlibdeps
@@ -50,7 +61,7 @@ debhelper (7.2.17) unstable; urgency=low
the new system also requires they have START-INFO-DIR-ENTRY and
END-INFO-DIR-ENTRY for proper registration. I assume there will be
some mass bug filing for any packages that do not have that.
- Closes: #528864, #357434
+ Closes: #534639, #357434
-- Joey Hess <joeyh@debian.org> Fri, 26 Jun 2009 09:02:51 -0400
diff --git a/dh_install b/dh_install
index 86a868bf..ccec4717 100755
--- a/dh_install
+++ b/dh_install
@@ -117,7 +117,7 @@ init(options => {
my @installed;
my $srcdir = '.';
-$srcdir = $dh{SOURCEDIR}."/" if defined $dh{SOURCEDIR};
+$srcdir = $dh{SOURCEDIR} if defined $dh{SOURCEDIR};
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
@@ -151,7 +151,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my @found = glob "$srcdir/$glob";
if (! compat(6)) {
# Fall back to looking in debian/tmp.
- if (! @found || ! -e $found[0]) {
+ if (! @found || ! (-e $found[0] || -l $found[0])) {
@found = glob "debian/tmp/$glob";
}
}
@@ -170,11 +170,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (! defined $dest) {
# Guess at destination directory.
$dest=$src;
- my $strip=$srcdir;
- if ($strip eq '.') {
- $strip = "debian/tmp";
- }
- $dest=~s/^(.*\/)?\Q$strip\E//;
+ $dest=~s/^(.*\/)?(\Q$srcdir\E|debian\/tmp)\///;
$dest=dirname($dest);
$tmpdest=1;
}