summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_strip2
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index c165b3f8..dc4bb832 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (4.0.7) unstable; urgency=low
+
+ * dh_strip: If a file is an ELF shared binary, does not have a .so.* in its
+ name, stirp it as a ELF binary. It seems that GNUstep has files of this
+ sort. See bug #35733 (not sufficient to close all of it).
+
+ -- Joey Hess <joeyh@debian.org> Wed, 22 May 2002 20:40:09 -0400
+
debhelper (4.0.6) unstable; urgency=low
* Make dh_clean remove autom4te.cache.
diff --git a/dh_strip b/dh_strip
index a62e440d..31d51aff 100755
--- a/dh_strip
+++ b/dh_strip
@@ -93,7 +93,7 @@ sub testfile {
if ($mode & 0111) {
# Ok, expensive test.
my $type=get_file_type($_);
- if ($type=~m/.*ELF.*executable.*/) {
+ if ($type=~m/.*ELF.*(executable|shared).*/) {
push @executables, $fn;
return;
}