summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--debian/control4
-rwxr-xr-xdh_installman2
3 files changed, 11 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 31c6bc26..2303e331 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (4.1.72) unstable; urgency=low
+
+ * Switch from build-depends-indep to just build-depends.
+ * dh_installman: match .so links with whitespace after the filename
+ Closes: #208753
+
+ -- Joey Hess <joeyh@debian.org> Fri, 5 Sep 2003 13:59:12 -0400
+
debhelper (4.1.71) unstable; urgency=low
* Typo. Closes: #207999
diff --git a/debian/control b/debian/control
index 95771531..9f0001ee 100644
--- a/debian/control
+++ b/debian/control
@@ -2,8 +2,8 @@ Source: debhelper
Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
-Build-Depends-Indep: perl (>= 5.6.1), coreutils | fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.9.0)
-Standards-Version: 3.6.0
+Build-Depends: perl (>= 5.6.1), coreutils | fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.9.0)
+Standards-Version: 3.6.1.0
Package: debhelper
Architecture: all
diff --git a/dh_installman b/dh_installman
index 9adca670..24c5c041 100755
--- a/dh_installman
+++ b/dh_installman
@@ -184,7 +184,7 @@ sub find_so_man {
open (SOTEST,$_) || die "$_: $!";
my $l=<SOTEST>;
close SOTEST;
- if ($l=~m/\.so\s+(.*)/) {
+ if ($l=~m/\.so\s+(.*)\s*/) {
my $solink=$1;
# This test is here to prevent links like ... man8/../man8/foo.8
if (basename($File::Find::dir) eq