summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rwxr-xr-xdh_testdir1
-rwxr-xr-xdh_testroot1
-rwxr-xr-xdh_testversion1
4 files changed, 6 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index b1870869..29148232 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,9 @@
-debhelper (7.0.5) UNRELEASED; urgency=low
+debhelper (7.0.5) unstable; urgency=low
* Convert copyright file to new format.
+ * dh_test*: inhibit logging. Closes: #478958
- -- Joey Hess <joeyh@debian.org> Wed, 30 Apr 2008 18:19:13 -0400
+ -- Joey Hess <joeyh@debian.org> Thu, 01 May 2008 19:52:00 -0400
debhelper (7.0.4) unstable; urgency=low
diff --git a/dh_testdir b/dh_testdir
index 451b9aeb..67ab9ea4 100755
--- a/dh_testdir
+++ b/dh_testdir
@@ -33,6 +33,7 @@ Test for the existence of these files too.
=cut
init();
+inhibit_log();
foreach my $file ('debian/control', @ARGV) {
if (! -e $file) {
diff --git a/dh_testroot b/dh_testroot
index 34684768..717d8841 100755
--- a/dh_testroot
+++ b/dh_testroot
@@ -18,6 +18,7 @@ L<fakeroot(1)>
use strict;
use Debian::Debhelper::Dh_Lib;
+inhibit_log();
if ($< != 0) {
error("You must run this as root (or use fakeroot).");
diff --git a/dh_testversion b/dh_testversion
index a17f22e9..9c1c391d 100755
--- a/dh_testversion
+++ b/dh_testversion
@@ -51,6 +51,7 @@ specified, dh_testversion does nothing.
=cut
init();
+inhibit_log();
my($compare, $ver);