summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debhelper.pod4
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules2
-rwxr-xr-xdh_installcatalogs2
-rwxr-xr-xdh_installman4
-rwxr-xr-xdh_installxfonts2
-rwxr-xr-x[-rw-r--r--]t/dh_link6
7 files changed, 20 insertions, 8 deletions
diff --git a/debhelper.pod b/debhelper.pod
index 3fa2e2d1..ad40d714 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -38,6 +38,10 @@ pages for additional documentation.
=back
+If a program's name starts with "dh_", and the program is not on the above
+list, then it is not part of the debhelper package, but it should still
+work like the other programs described on this page.
+
=head1 DEBHELPER CONFIG FILES
Many debhelper commands make use of files in F<debian/> to control what they
diff --git a/debian/changelog b/debian/changelog
index 4c03e6d8..3d0cec68 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (4.1.56) unstable; urgency=low
+
+ * Several man pae typo fixes by Ruben Porras. Closes: #202819
+ * Now in a subversion repository, some minor changes for that.
+ * dh_link test should expect results in debian/debhelper, not debian/tmp.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 28 Jul 2003 15:36:45 -0400
+
debhelper (4.1.55) unstable; urgency=low
* dh_strip: do not strip files multiple times.
diff --git a/debian/rules b/debian/rules
index ffb2c9ba..0c22f0e4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -56,7 +56,7 @@ clean:
test: test-stamp
test-stamp:
./dh_clean
- DH_VERSION=10 perl -MTest::Harness -e 'runtests grep { ! /CVS/ } @ARGV' t/*
+ DH_VERSION=10 perl -MTest::Harness -e 'runtests grep { ! /CVS/ && ! /\.svn/ } @ARGV' t/*
./dh_clean
touch test-stamp
diff --git a/dh_installcatalogs b/dh_installcatalogs
index fdaf0fa7..eef8cdeb 100755
--- a/dh_installcatalogs
+++ b/dh_installcatalogs
@@ -17,7 +17,7 @@ B<dh_installcatalogs> [S<I<debhelper options>>] [B<-n>]
=head1 DESCRIPTION
-dh_installcatalog is a debhelper program that installs and
+dh_installcatalogs is a debhelper program that installs and
registers SGML catalogs. (Note: it will be extended for XML catalog
registration when xml-core is available.) It complies with the Debian
XML/SGML policy.
diff --git a/dh_installman b/dh_installman
index 59db6838..6ee00091 100755
--- a/dh_installman
+++ b/dh_installman
@@ -23,8 +23,8 @@ install them based on the section field in their .TH line. If you have a
properly formatted .TH line, your man page will be installed into the right
directory, with the right name (this includes proper handling of pages
with a subsection, like "3perl", which are placed in man3, and given an
-extention of ".3perl"). If your .TH line is incorrect or missing, the program
-may guess wrong based on the file extention.
+extension of ".3perl"). If your .TH line is incorrect or missing, the program
+may guess wrong based on the file extension.
It also supports translated man pages, by looking for extensions
like .ll.8 and .ll_LL.8
diff --git a/dh_installxfonts b/dh_installxfonts
index 984144b4..c60178db 100755
--- a/dh_installxfonts
+++ b/dh_installxfonts
@@ -25,7 +25,7 @@ directory, and if you have fonts.alias or fonts.scale files, you should
install them into the correct location under etc/X11/fonts in your package
build directory.
-Your package should should depend on xutils (>= 4.0.3) so that the
+Your package should depend on xutils (>= 4.0.3) so that the
update-fonts-* commands are available. (This program adds that dependency to
${misc:Depends}.)
diff --git a/t/dh_link b/t/dh_link
index 9f644e78..3ab345e8 100644..100755
--- a/t/dh_link
+++ b/t/dh_link
@@ -5,12 +5,12 @@ plan(tests => 3);
# It used to not make absolute links in this situation, and it should.
# #37774
system("./dh_link","etc/foo","usr/lib/bar");
-ok("/etc/foo",readlink("debian/tmp/usr/lib/bar"));
+ok("/etc/foo",readlink("debian/debhelper/usr/lib/bar"));
# let's make sure it makes simple relative links ok.
system("./dh_link","usr/bin/foo","usr/bin/bar");
-ok("foo",readlink("debian/tmp/usr/bin/bar"));
+ok("foo",readlink("debian/debhelper/usr/bin/bar"));
# ok, more complex relative links.
system("./dh_link","usr/lib/1","usr/bin/2");
-ok("../lib/1",readlink("debian/tmp/usr/bin/2"));
+ok("../lib/1",readlink("debian/debhelper/usr/bin/2"));