summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debhelper.pod2
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rwxr-xr-xdh_makeshlibs2
4 files changed, 10 insertions, 3 deletions
diff --git a/debhelper.pod b/debhelper.pod
index 4723036e..a93034e5 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -234,7 +234,7 @@ turn this off and use those characters raw, just prefix with a backslash.
dh_makeshlibs makes the postinst and postrm scripts call ldconfig.
-=item
+=item -
Every file in etc/ is automatically flagged as a conffile by dh_installdeb.
diff --git a/debian/changelog b/debian/changelog
index 7a235fc9..bd59672e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (3.0.7) unstable; urgency=low
+
+ * dh_makeshlibs: only generate call to ldconfig if it really looks like
+ a given *.so* file is indeed a shared library.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 23 Feb 2001 14:38:50 -0800
+
debhelper (3.0.6) unstable; urgency=low
* Corrected some uninitialized value stuff in dh_suidregister (actually
diff --git a/debian/control b/debian/control
index eaef624d..48ad49b7 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
Build-Depends-Indep: perl-5.6, fileutils (>= 4.0-2.1), file (>= 3.23-1)
-Standards-Version: 3.5.1.0
+Standards-Version: 3.5.2.0
Package: debhelper
Architecture: all
diff --git a/dh_makeshlibs b/dh_makeshlibs
index de29453c..1888ee2d 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -94,7 +94,6 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my $major;
chomp;
- $need_ldconfig=1;
# The second evil regexp is for db3, whose author should
# be shot.
if (m#.*/([^/]*)\.so\.(\d*)\.?# || m#.*/([^/]*)-([^\s/]+)\.so$#) {
@@ -121,6 +120,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
if (defined($library) && defined($major) && defined($deps) &&
$library ne '' && $major ne '' && $deps ne '') {
+ $need_ldconfig=1;
# Prevent duplicate lines from entering the file.
my $line="$library $major $deps";
if (! $seen{$line}) {