summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/perl_makemaker.pm3
-rw-r--r--debian/changelog7
2 files changed, 10 insertions, 0 deletions
diff --git a/Debian/Debhelper/Buildsystem/perl_makemaker.pm b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
index a7bb5cc9..46dda4f8 100644
--- a/Debian/Debhelper/Buildsystem/perl_makemaker.pm
+++ b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
@@ -39,6 +39,9 @@ sub configure {
# If set to a true value then MakeMaker's prompt function will
# # always return the default without waiting for user input.
$ENV{PERL_MM_USE_DEFAULT}=1;
+ # This prevents Module::Install from interactive behavior.
+ $ENV{PERL_AUTOINSTALL}="--skipdeps";
+
doit("perl", "Makefile.PL", "INSTALLDIRS=vendor",
"create_packlist=0",
@_);
diff --git a/debian/changelog b/debian/changelog
index 8a76e1c7..8d158786 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -15,6 +15,13 @@ debhelper (7.3.0) UNRELEASED; urgency=low
-- Joey Hess <joeyh@debian.org> Mon, 20 Apr 2009 16:26:08 -0400
+debhelper (7.2.13) unstable; urgency=low
+
+ * dh_auto_configure: Pass --skipdeps safely via PERL_AUTOINSTALL.
+ Closes: #528235
+
+ -- Joey Hess <joeyh@debian.org> Thu, 14 May 2009 15:21:21 -0400
+
debhelper (7.2.12) unstable; urgency=low
* dh_auto_configure: Revert --skipdeps change