summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_link5
-rwxr-xr-xdh_python13
-rw-r--r--doc/TODO4
4 files changed, 22 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index e305c64a..61cc5cfb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (4.1.67) unstable; urgency=low
+
+ * dh_python: Another patch, for pythonX.Y-foo packages.
+ * dh_link: Improve error message if link destination is a directory.
+ Closes: #206689
+
+ -- Joey Hess <joeyh@debian.org> Fri, 22 Aug 2003 12:48:19 -0400
+
debhelper (4.1.66) unstable; urgency=low
* dh_link: rm -f every time, ln -f is not good enough if the link target
diff --git a/dh_link b/dh_link
index 8e66d671..7c51d06c 100755
--- a/dh_link
+++ b/dh_link
@@ -162,7 +162,10 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Make sure it's properly absolute.
$src="/$src";
}
-
+
+ if (-d "$tmp/$dest" && ! -l "$tmp/$dest") {
+ error("link destination $tmp/$dest is a directory");
+ }
doit("rm", "-f", "$tmp/$dest");
doit("ln","-sf", $src, "$tmp/$dest");
}
diff --git a/dh_python b/dh_python
index 952a77d9..5c19ef7d 100755
--- a/dh_python
+++ b/dh_python
@@ -126,7 +126,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my $strong_dep = 0;
my $look_for_pythonXY = 1;
- # First, the case of python-foo
+ # First, the case of python-foo and pythonX.Y-foo
if ($package =~ /^python-/) {
$dep_on_python = 1;
$strong_dep = 1;
@@ -135,11 +135,11 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (grep { "$_" eq "$pack" } GetPackages()) {
addsubstvar($package, "python:Depends", $pack);
}
- else {
- push @dirs, "usr/lib/python$python_version/site-packages" ;
- push @dirs_so, "usr/lib/python$python_version/site-packages" ;
- $look_for_pythonXY = 0;
- }
+ }
+ if ($package !~ /^python[0-9].[0-9]-/) {
+ push @dirs, "usr/lib/python$python_version/site-packages" ;
+ push @dirs_so, "usr/lib/python$python_version/site-packages" ;
+ $look_for_pythonXY = 0;
}
@dirs = grep -d, map "$tmp/$_", @dirs;
@@ -274,4 +274,3 @@ Josselin Mouette <joss@debian.org>
most ideas stolen from Brendan O'Dea <bod@debian.org>
=cut
-
diff --git a/doc/TODO b/doc/TODO
index 7dc57ff5..fdeb606f 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -34,6 +34,10 @@ Wishlist items:
--section is not given. So I should be able to stop parsing it myself for
section, after dpkg 1.10 has been around long enough.
+* Support comments in config files? (#206422)
+* dh_installppp
+* dh_installnetwork
+
Deprecated:
* DH_COMPAT 1. Can be removed once all packages are seen to be using 2 or