summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_install4
2 files changed, 9 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index b2e10d17..ae50371a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.0.17) unstable; urgency=low
+
+ * In dh_install, don't limit to -type f when doing the find due to -X.
+ This makes it properly install syml8inks, cf my rpm bug.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 5 Jul 2002 22:58:03 -0400
+
debhelper (4.0.16) unstable; urgency=low
* Patch from doogie to make dh_movefiles support -X. Closes: #150978
diff --git a/dh_install b/dh_install
index 65a99772..69f24365 100755
--- a/dh_install
+++ b/dh_install
@@ -109,7 +109,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Support for -X flag.
my $exclude = '';
if ($dh{EXCLUDE_FIND}) {
- $exclude = ' -and ! \( '.$dh{EXCLUDE_FIND}.' \)';
+ $exclude = '-and ! \( '.$dh{EXCLUDE_FIND}.' \)';
}
foreach my $set (@install) {
@@ -139,7 +139,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Pity there's no cp --exclude ..
my $pwd=`pwd`;
chomp $pwd;
- complex_doit("cd $src/.. && find $dir_basename -type f$exclude -exec cp --parents -dp {} $pwd/$tmp/$dest/ \\;");
+ complex_doit("cd $src/.. && find $dir_basename \\( -type f -or -type l \\) $exclude -exec cp --parents -dp {} $pwd/$tmp/$dest/ \\;");
}
else {
doit("cp", "-a", $src, "$tmp/$dest/");