summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_fixperms8
2 files changed, 10 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 68987b7e..cf0ba10b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (8.9.8) UNRELEASED; urgency=low
+
+ * dh_fixperms: Operate on .ali files throughout /usr/lib, including
+ multiarch dirs. Closes: #641279
+
+ -- Joey Hess <joeyh@debian.org> Mon, 12 Sep 2011 13:35:52 -0400
+
debhelper (8.9.7) unstable; urgency=low
* dh: Now you can use override_dh_command-arch and override_dh_command-indep
diff --git a/dh_fixperms b/dh_fixperms
index 3730b49d..d6e237bc 100755
--- a/dh_fixperms
+++ b/dh_fixperms
@@ -105,11 +105,9 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
# ADA ali files should be mode 444 to avoid recompilation
- if (-d "$tmp/usr/lib/ada") {
- complex_doit("find $tmp/usr/lib/ada -type f",
- "-name '*.ali' $find_options -print0",
- "2>/dev/null | xargs -0r chmod uga-w");
- }
+ complex_doit("find $tmp/usr/lib -type f",
+ "-name '*.ali' $find_options -print0",
+ "2>/dev/null | xargs -0r chmod uga-w");
# Lintian overrides should never be executable, too.
if (-d "$tmp/usr/share/lintian") {