summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_auto_install1
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index a82d4c62..deae621d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ debhelper (7.2.18) UNRELEASED; urgency=low
* dh_shlibdeps: Ensure DEBIAN directory exists, as dpkg-shlibdeps
prints a confusing warning if it does not. Closes: #534226
+ * dh_auto_install: Pass --install-layout=deb to setup.py
+ to support python 2.6. Closes: #534620
-- Joey Hess <joeyh@debian.org> Sun, 28 Jun 2009 15:59:11 -0400
diff --git a/dh_auto_install b/dh_auto_install
index 264725ca..61ed9044 100755
--- a/dh_auto_install
+++ b/dh_auto_install
@@ -87,6 +87,7 @@ elsif (-e "setup.py") {
doit("python", "setup.py", "install",
"--root=$destdir",
"--no-compile", "-O0",
+ "--install-layout=deb",
@{$dh{U_PARAMS}});
}
elsif (-e "Build.PL" && -e "Build") {