summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postinst-menu3
-rw-r--r--autoscripts/postrm-menu1
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_installmenu18
4 files changed, 13 insertions, 17 deletions
diff --git a/autoscripts/postinst-menu b/autoscripts/postinst-menu
deleted file mode 100644
index b56a3462..00000000
--- a/autoscripts/postinst-menu
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ "$1" = "configure" ] && [ -x "`which update-menus 2>/dev/null`" ]; then
- update-menus
-fi
diff --git a/autoscripts/postrm-menu b/autoscripts/postrm-menu
deleted file mode 100644
index a180558d..00000000
--- a/autoscripts/postrm-menu
+++ /dev/null
@@ -1 +0,0 @@
-if [ -x "`which update-menus 2>/dev/null`" ]; then update-menus ; fi
diff --git a/debian/changelog b/debian/changelog
index e5377d3b..09f692c1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (7.2.3) UNRELEASED; urgency=low
+
+ * dh_installmenus: Now that a triggers capable menu and dpkg are in
+ stable, menu does not need to be explicitly run in maintainer
+ scripts, except for packages with menu-methods files. (See #473467)
+
+ -- Joey Hess <joeyh@debian.org> Fri, 06 Mar 2009 13:57:47 -0500
+
debhelper (7.2.2) unstable; urgency=low
* dh_installmodules: Give files in /etc/modprobe.d a .conf
diff --git a/dh_installmenu b/dh_installmenu
index 327fac0f..963f546f 100755
--- a/dh_installmenu
+++ b/dh_installmenu
@@ -18,18 +18,17 @@ B<dh_installmenu> [S<B<debhelper options>>] [B<-n>]
dh_installmenu is a debhelper program that is responsible for installing
files used by the debian menu package into package build directories.
-It also automatically generates the postinst and postrm commands needed to
-interface with the debian menu package. These commands are inserted into
-the maintainer scripts by dh_installdeb. See L<dh_installdeb(1)> for an
-explanation of how this works.
-
If a file named debian/package.menu exists, then it is installed into
usr/share/menu/package in the package build directory. This is a debian menu
file. See L<menufile(5)> for its format.
If a file named debian/package.menu-method exits, then it is installed into
etc/menu-methods/package in the package build directory. This is a debian
-menu method file.
+menu method file. In this case, dh_installmenu also automatically generates
+the postinst and postrm commands needed to
+interface with the debian menu package. These commands are inserted into
+the maintainer scripts by dh_installdeb. See L<dh_installdeb(1)> for an
+explanation of how this works.
=head1 OPTIONS
@@ -55,13 +54,6 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
doit("install","-d","$tmp/usr/share/menu");
}
doit("install","-p","-m644",$menu,"$tmp/usr/share/menu/$package");
-
- # Add the scripts if a menu-method file doesn't exist.
- # The scripts for menu-method handle everything these do, too.
- if ($menu_method eq "" && ! $dh{NOSCRIPTS}) {
- autoscript($package,"postinst","postinst-menu");
- autoscript($package,"postrm","postrm-menu")
- }
}
if ($menu_method ne '') {